Project

General

Profile

Bug #24025

RocksDB compression is not supported at least on Debian.

Added by Марк Коренберг 11 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/06/2018
Due date:
% Done:

0%

Source:
Tags:
rocksdb compression
Backport:
mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

rocksdb: Compression algorithms supported:
rocksdb:     Snappy supported: 0
rocksdb:     Zlib supported: 0
rocksdb:     Bzip supported: 0
rocksdb:     LZ4 supported: 0
rocksdb:     ZSTD supported: 0

see #22534


Related issues

Copied to RADOS - Backport #24279: luminous: RocksDB compression is not supported at least on Debian. Resolved
Copied to RADOS - Backport #24297: mimic: RocksDB compression is not supported at least on Debian. Resolved

History

#1 Updated by Марк Коренберг 11 months ago

I use:

deb https://download.ceph.com/debian-luminous/ stretch main

Ceph 12.2.5 and Debian 9.

#2 Updated by Radoslaw Zarzynski 10 months ago

  • Assignee set to Radoslaw Zarzynski

#3 Updated by Radoslaw Zarzynski 10 months ago

  • Status changed from New to In Progress
void DumpSupportInfo(Logger* logger) {
  ROCKS_LOG_HEADER(logger, "Compression algorithms supported:");
  for (auto& compression : OptionsHelper::compression_type_string_map) {
    if (compression.second != kNoCompression &&
        compression.second != kDisableCompressionOption) {
      ROCKS_LOG_HEADER(logger, "\t%s supported: %d", compression.first.c_str(),
                       CompressionTypeSupported(compression.second));
    }
  }
  ROCKS_LOG_HEADER(logger, "Fast CRC32 supported: %s",
                   crc32c::IsFastCrc32Supported().c_str());
} 

inline bool CompressionTypeSupported(CompressionType compression_type) {
  switch (compression_type) {
    case kNoCompression:
      return true;
    case kSnappyCompression:
      return Snappy_Supported();
    case kZlibCompression:
      return Zlib_Supported();
    case kBZip2Compression:
      return BZip2_Supported();
    case kLZ4Compression:
      return LZ4_Supported();
    case kLZ4HCCompression:
      return LZ4_Supported();
    case kXpressCompression:
      return XPRESS_Supported();
    case kZSTDNotFinalCompression:
      return ZSTDNotFinal_Supported();
    case kZSTD:
      return ZSTD_Supported();
    default:
      assert(false);
      return false;
  }   
}
inline bool Snappy_Supported() {
#ifdef SNAPPY
  return true;
#else
  return false;
#endif
}

It looks that the macros SNAPPY, ZLIB, ... are undefined on Debian. Need to check why.

#4 Updated by Kefu Chai 10 months ago

because we fail to pass -DWITH_SNAPPY etc to cmake while building rocksdb. this bug also impacts rpm package. i can help pull together a patch.

#5 Updated by Kefu Chai 10 months ago

  • Project changed from bluestore to RADOS
  • Assignee changed from Radoslaw Zarzynski to Kefu Chai

#6 Updated by Kefu Chai 10 months ago

  • Status changed from In Progress to Need Review

#7 Updated by Kefu Chai 10 months ago

  • Backport set to mimic, luminous

#9 Updated by Kefu Chai 10 months ago

tested

2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb: Compression algorithms supported:
2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb:    kZSTDNotFinalCompression supported: 0
2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb:    kZSTD supported: 0
2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb:    kXpressCompression supported: 0
2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb:    kLZ4HCCompression supported: 1
2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb:    kLZ4Compression supported: 1
2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb:    kBZip2Compression supported: 0
2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb:    kZlibCompression supported: 1
2018-05-24 17:41:26.398 7f3cc22d22c0  4 rocksdb:    kSnappyCompression supported: 1

#10 Updated by Kefu Chai 10 months ago

  • Status changed from Need Review to Pending Backport

#11 Updated by Kefu Chai 10 months ago

  • Copied to Backport #24279: luminous: RocksDB compression is not supported at least on Debian. added

#12 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #24297: mimic: RocksDB compression is not supported at least on Debian. added

#13 Updated by Nathan Cutler 9 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF