Project

General

Profile

Bug #23923

mds: stopping rank 0 cannot shutdown until log is trimmed

Added by Patrick Donnelly 11 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
Start date:
04/28/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:

Description

2018-04-28 06:46:10.353 7fa3644fa700 20 mds.0.locker caps_tick 0 revoking caps
2018-04-28 06:46:10.353 7fa3644fa700 20 mds.0.26 updating export targets, currently 0 ranks are targets
2018-04-28 06:46:10.353 7fa3644fa700 10 mds.0.log trim 1 / 128 segments, 1 / -1 events, 0 (0) expiring, 0 (0) expired
2018-04-28 06:46:10.353 7fa3644fa700 10 mds.0.log _trim_expired_segments waiting for 1/4196486 to expire
2018-04-28 06:46:10.353 7fa3644fa700  7 mds.0.cache shutdown_pass
2018-04-28 06:46:10.353 7fa3644fa700  7 mds.0.cache trim bytes_used=51kB limit=1GB reservation=0.05% count=18446744073709551615
2018-04-28 06:46:10.353 7fa3644fa700  7 mds.0.cache trim_lru trimming 18446744073709551615 items from LRU size=10 mid=7 pintail=0 pinned=10
2018-04-28 06:46:10.353 7fa3644fa700  7 mds.0.cache trim_lru trimmed 0 items
2018-04-28 06:46:10.353 7fa3644fa700  5 mds.0.cache lru size now 10/0
2018-04-28 06:46:10.353 7fa3644fa700  7 mds.0.cache still have 2 subtrees

From: /ceph/teuthology-archive/pdonnell-2018-04-28_06:20:24-fs-wip-pdonnell-testing-20180428.041811-testing-basic-smithi/2449342/remote/smithi031/log/ceph-mds.c.log.gz

(I think that's the cause anyway.)


Related issues

Copied to fs - Backport #23950: luminous: mds: stopping rank 0 cannot shutdown until log is trimmed Resolved

History

#1 Updated by Patrick Donnelly 11 months ago

  • Status changed from New to Need Review

#2 Updated by Patrick Donnelly 11 months ago

  • Backport set to luminous

#3 Updated by Patrick Donnelly 11 months ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #23950: luminous: mds: stopping rank 0 cannot shutdown until log is trimmed added

#5 Updated by Nathan Cutler 10 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF