Project

General

Profile

Bug #23610

pg stuck in activating because of dropped pg-temp message

Added by Kefu Chai 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/10/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

http://pulpito.ceph.com/yuriw-2018-04-05_22:33:03-rados-wip-yuri3-testing-2018-04-05-1940-luminous-distro-basic-smithi/2358623

1. mon sent pg-create(1.0) to osd.1
2. osd.1 created 1.0 with acting set of [1,0]. pg 1.0 was active+clean by then.
3. osd.0 was down
4. osd.1 consumed the new osdmap, the up and acting set of pg 1.0 were [1,2], it started peering.
5. osd.1 notified osd.2 that it should create replica of pg 1.0
6. osd.2 withheld the creating of pg 1.0 because its "max-pg-per-osd" was 1
7. osd.2 removed all created pgs
8. osd.2 tried to a osd-pgtemp to mon. but the connection was reset.
9. osd.2 reconnected to mon, but the osd-pgtemp was not resent because the osd-mon connection is lossy.
10.osd.2 never resent the osd-pgtemp..


Related issues

Related to RADOS - Bug #23648: max-pg-per-osd.from-primary fails because of activating pg New 04/11/2018
Copied to RADOS - Backport #23630: luminous: pg stuck in activating Resolved

History

#1 Updated by Kefu Chai 12 months ago

  • Status changed from New to Need Review

#2 Updated by Nathan Cutler 12 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 12 months ago

#4 Updated by Nathan Cutler 12 months ago

  • Status changed from Pending Backport to Need Review

#5 Updated by Kefu Chai 12 months ago

  • Related to Bug #23648: max-pg-per-osd.from-primary fails because of activating pg added

#6 Updated by Kefu Chai 12 months ago

  • Subject changed from pg stuck in activating to pg stuck in activating because of dropped pg-temp message

#7 Updated by Kefu Chai 12 months ago

  • Status changed from Need Review to Pending Backport

#8 Updated by Nathan Cutler 11 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF