Project

General

Profile

Bug #23587

rgw:failed to pass test_bucket_create_naming_bad_punctuation in s3test

Added by joke lee about 1 year ago. Updated 3 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
04/08/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

hi,
i run s3test in ceph master branch and failed to pass test_bucket_create_naming_bad_punctuation

it raise 403 signature not match rather 400 bad bucket name, the bucket name alpha!soup should uri encode for s3 authorization in canonical_uri


Related issues

Copied to rgw - Backport #39359: mimic: rgw:failed to pass test_bucket_create_naming_bad_punctuation in s3test Resolved
Copied to rgw - Backport #39360: luminous: rgw:failed to pass test_bucket_create_naming_bad_punctuation in s3test Resolved

History

#2 Updated by Greg Farnum about 1 year ago

  • Project changed from Ceph to rgw

#3 Updated by Orit Wasserman about 1 year ago

  • Status changed from New to Need Test
  • Assignee set to Matt Benjamin

#4 Updated by Matt Benjamin about 2 months ago

  • Status changed from Need Test to Pending Backport
  • Backport set to mimic,luminous

#5 Updated by Nathan Cutler about 2 months ago

  • Copied to Backport #39359: mimic: rgw:failed to pass test_bucket_create_naming_bad_punctuation in s3test added

#6 Updated by Nathan Cutler about 2 months ago

  • Copied to Backport #39360: luminous: rgw:failed to pass test_bucket_create_naming_bad_punctuation in s3test added

#7 Updated by Nathan Cutler 3 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF