Project

General

Profile

Bug #23298

filestore: do_copy_range replay bad return value

Added by Sage Weil about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/10/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

+ if (r < 0 && replaying) {
+ assert(r == -ERANGE);
+ derr << "Filestore: short source tolerated because we are replaying" << dendl;
+ r = pos - from;;
+ }

pos is an offset, from is an fd.

/a/sage-2018-03-09_22:32:43-rados-wip-sage2-testing-2018-03-09-1346-distro-basic-smithi/2272809/remote/smithi094/idempotent_failure


Related issues

Copied to RADOS - Backport #23351: luminous: filestore: do_copy_range replay bad return value Resolved

History

#2 Updated by Sage Weil about 1 year ago

  • Description updated (diff)

#3 Updated by Sage Weil about 1 year ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #23351: luminous: filestore: do_copy_range replay bad return value added

#5 Updated by Nathan Cutler 12 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF