Project

General

Profile

Bug #23259

extend $PATH further

Added by Alfredo Deza over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/07/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Now that http://tracker.ceph.com/issues/22841 is fixed, extra additions to standard $PATH locations is needed.

Some executables exist in /sbin/ and are not being detected. This doesn't result in failure because ceph-volume is falling back to
using the executable without an absolute path.

Some example of this:

$ which vgcreate
/sbin/vgcreate
$ which mkfs
/sbin/mkfs
$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

History

#1 Updated by Alfredo Deza over 1 year ago

  • Status changed from New to Need Review

#2 Updated by Alfredo Deza over 1 year ago

  • Status changed from Need Review to Resolved

merged commit a8cd8b2 into master

Also available in: Atom PDF