Project

General

Profile

Bug #23041

ceph-fuse: clarify -i is not a valid option

Added by Patrick Donnelly 11 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Category:
Administration/Usability
Target version:
Start date:
03/05/2018
Due date:
% Done:

100%

Source:
Development
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
ceph-fuse
Labels (FS):
Pull request ID:

Description

Using:

ceph-fuse -i foo

is not valid since:

commit 8e3abf3ce337ac4ac58d2d4f68fbedf5c3918175 8e3abf3ce33
Author: Colin Patrick McCabe <cmccabe@alumni.cmu.edu>
Date:   Thu Mar 10 07:41:50 2011 -0800

    Don't use -i to set id for non-daemons

    Due to conflicts, don't use -i to set id except for daemons.

    Signed-off-by: Colin McCabe <colin.mccabe@dreamhost.com>

(however, --id is okay.) We should remove -i from the help output/docs.


Subtasks

Bug #23084: doc: update ceph-fuse with FUSE optionsResolvedJos Collin

Bug #23214: doc: Fix -d option in ceph-fuse docResolvedJos Collin


Related issues

Copied to fs - Backport #23156: luminous: ceph-fuse: clarify -i is not a valid option Resolved

History

#1 Updated by Patrick Donnelly 11 months ago

  • Status changed from New to Need Review

#2 Updated by Patrick Donnelly 11 months ago

  • Status changed from Need Review to Pending Backport
  • Target version set to v13.0.0

#3 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #23156: luminous: ceph-fuse: clarify -i is not a valid option added

#4 Updated by Nathan Cutler 10 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF