Project

General

Profile

Bug #22920

filestore journal replay does not guard omap operations

Added by Sage Weil about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
02/05/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

omap operations are replayed without checking the guards, which means that omap data can leak between objects that are cloned.


Related issues

Copied to RADOS - Backport #22934: luminous: filestore journal replay does not guard omap operations Resolved

History

#1 Updated by Sage Weil about 1 year ago

  • Backport set to luminous,jewel

#2 Updated by Sage Weil about 1 year ago

  • Status changed from Need Review to Pending Backport
  • Backport changed from luminous,jewel to luminous

#3 Updated by Sage Weil about 1 year ago

  • Priority changed from Immediate to High

lowering the priority since in practice we don't clone objects with omap on them.

#4 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #22934: luminous: filestore journal replay does not guard omap operations added

#5 Updated by Nathan Cutler 10 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF