Project

General

Profile

Bug #22655

rgw: Location element not returned correctly from CompleteMultipartUpload

Added by Matt Benjamin 6 months ago. Updated 1 day ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/10/2018
Due date:
% Done:

0%

Source:
Support
Tags:
Backport:
luminous,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

Per https://docs.aws.amazon.com/AmazonS3/latest/API/mpUploadComplete.html, the <Location> element in the HTTP response body should contain a (or the) HTTP URI "that identifies the newly created object."

RGW has not been doing this.


Related issues

Copied to rgw - Backport #22905: luminous: rgw: Location element not returned correctly from CompleteMultipartUpload Resolved
Copied to rgw - Backport #24944: jewel: rgw: Location element not returned correctly from CompleteMultipartUpload In Progress

History

#1 Updated by Matt Benjamin 6 months ago

  • Status changed from In Progress to Need Review

#3 Updated by Yehuda Sadeh 6 months ago

  • Status changed from Need Review to Testing

#4 Updated by Matt Benjamin 6 months ago

  • Status changed from Testing to Pending Backport

#5 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #22905: luminous: rgw: Location element not returned correctly from CompleteMultipartUpload added

#6 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

#7 Updated by Nathan Cutler 1 day ago

  • Status changed from Resolved to Pending Backport
  • Target version deleted (v13.0.0)
  • Backport changed from luminous to luminous,jewel

#8 Updated by Nathan Cutler 1 day ago

  • Copied to Backport #24944: jewel: rgw: Location element not returned correctly from CompleteMultipartUpload added

Also available in: Atom PDF