Project

General

Profile

Bug #22526

AttributeError: 'LocalFilesystem' object has no attribute 'ec_profile'

Added by Ramana Raja about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Testing
Target version:
Start date:
12/21/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
fs
Component(FS):
qa-suite
Labels (FS):
Pull request ID:

Description

Hit an error while running a ceph_volume_client test on a vstart Ceph cluster using the command
LD_LIBRARY_PATH=`pwd`/lib PYTHONPATH=/home/rraja/git/teuthology/:`pwd`/../qa:`pwd`/../src/pybind:`pwd`/lib/cython_modules/lib.2 python `pwd`/../qa/tasks/vstart_runner.py --interactive tasks.cephfs.test_volume_client.TestVolumeClient.test_lifecycle

2017-12-21 19:35:46,370.370 ERROR:__main__:Traceback (most recent call last):
File "/home/rraja/git/ceph/qa/tasks/cephfs/cephfs_test_case.py", line 146, in setUp
self.fs = self.mds_cluster.newfs(create=True)
File "/home/rraja/git/ceph/build/../qa/tasks/vstart_runner.py", line 659, in newfs
return LocalFilesystem(self._ctx, name=name, create=create)
File "/home/rraja/git/ceph/build/../qa/tasks/vstart_runner.py", line 708, in init
self.create()
File "/home/rraja/git/ceph/qa/tasks/cephfs/filesystem.py", line 481, in create
if self.ec_profile:
AttributeError: 'LocalFilesystem' object has no attribute 'ec_profile'

Looks like the error existed since https://github.com/ceph/ceph/commit/d0732fc9#diff-b3a56ab86d2e46ef827df2b8b21fc142R478

Needs a minor fix in qa/tasks/vstart_runner.py


Related issues

Copied to fs - Backport #22573: luminous: AttributeError: 'LocalFilesystem' object has no attribute 'ec_profile' Resolved

History

#1 Updated by Patrick Donnelly about 1 year ago

  • Status changed from In Progress to Pending Backport
  • Backport set to luminous

#2 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #22573: luminous: AttributeError: 'LocalFilesystem' object has no attribute 'ec_profile' added

#3 Updated by Nathan Cutler about 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF