Project

General

Profile

Bug #22261

Object remaining in domain_root pool after delete bucket

Added by Diluga Salome about 1 year ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Target version:
Start date:
11/28/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

we use boto to create&delete bucket,after bucket was deleted,the .bucket.meta still in domain_root pool,it is a bug?

```
from boto.s3.connection import S3Connection
import boto

conn = boto.connect_s3(
aws_access_key_id = '',
aws_secret_access_key = '',
host = 's3.demo.com',
port = 80,
is_secure = False,
calling_format = boto.s3.connection.OrdinaryCallingFormat(),
)
bucket = conn.create_bucket('foo')
#bucket.delete()
```

after create bucket 'foo',the domain_root pool look like:

```
root@host:/home/demo# rados ls -p rgw.root
foo
.bucket.meta.foo:70af9a54-20bb-480b-92f4-cbdeef0b775c.220604.1
```

after delete bucket 'foo',the domain_root pool look like:

```
root@host:/home/demo# rados ls -p rgw.root
.bucket.meta.foo:70af9a54-20bb-480b-92f4-cbdeef0b775c.220604.1 #not delete?
```

ceph version 10.2.10

History

#1 Updated by Orit Wasserman 11 months ago

If you use multisite than the bucket metadata and index won't be deleted.

#2 Updated by Matt Benjamin 11 months ago

  • Status changed from New to Need More Info

#3 Updated by Yehuda Sadeh 11 months ago

  • Status changed from Need More Info to Duplicate

Duplicate of #20802

Also available in: Atom PDF