Project

General

Profile

Bug #22046

Dynamic bucket indexing, resharding and tenants seems to be broken

Added by Mark Schouten over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
11/06/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:

Description

I see issues with resharding. rgw logging shows the following:
2017-10-20 15:17:30.018807 7fa1b219a700 -1 ERROR: failed to get entry from reshard log, oid=reshard.0000000013 tenant= bucket=qnapnas

radosgw-admin shows me there is one bucket in the queue to do resharding for:
radosgw-admin reshard list
[ {
"time": "2017-10-20 12:37:28.575096Z",
"tenant": "DB0339",
"bucket_name": "qnapnas",
"bucket_id": "1c19a332-7ffc-4472-b852-ec4a143785cc.19675875.3",
"new_instance_id": "",
"old_num_shards": 1,
"new_num_shards": 4
}
]

But, the tenant field in the logging entry is emtpy, which makes me expect that the tenant part is partially implemented.

Also, I can add "DB0339/qnapnas" to the list:
radosgw-admin reshard add --bucket DB0339/qnapnas --num-shards 4

But not like this:
radosgw-admin reshard add --bucket qnapnas --tenant DB0339 --num-shards 4
ERROR: --tenant is set, but there's no user ID


Related issues

Copied to rgw - Backport #22184: luminous: Dynamic bucket indexing, resharding and tenants seems to be broken Resolved

History

#1 Updated by Orit Wasserman over 1 year ago

  • Assignee set to Orit Wasserman

#2 Updated by Orit Wasserman over 1 year ago

  • Status changed from New to Need Review

#3 Updated by Casey Bodley over 1 year ago

  • Status changed from Need Review to Pending Backport
  • Backport set to luminous

#4 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #22184: luminous: Dynamic bucket indexing, resharding and tenants seems to be broken added

#5 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF