Project

General

Profile

Bug #21985

mds: definition of MDS_FEATURE_INCOMPAT_FILE_LAYOUT_V2 is wrong

Added by Zheng Yan over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
10/31/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:

Description

it's ID is the same as MDS_FEATURE_INCOMPAT_NOANCHOR


Related issues

Related to fs - Bug #23172: mds: fixed MDS_FEATURE_INCOMPAT_FILE_LAYOUT_V2 definition breaks luminous upgrades Resolved 02/28/2018
Copied to fs - Backport #22067: luminous: mds: definition of MDS_FEATURE_INCOMPAT_FILE_LAYOUT_V2 is wrong Resolved

History

#1 Updated by Zheng Yan over 1 year ago

  • Status changed from New to Need Review

#2 Updated by Patrick Donnelly over 1 year ago

  • Subject changed from definition of MDS_FEATURE_INCOMPAT_FILE_LAYOUT_V2 is wrong to mds: definition of MDS_FEATURE_INCOMPAT_FILE_LAYOUT_V2 is wrong
  • Assignee set to Zheng Yan
  • Source set to Development
  • Backport set to luminous
  • Component(FS) MDS added

#3 Updated by Patrick Donnelly over 1 year ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Patrick Donnelly over 1 year ago

  • Copied to Backport #22067: luminous: mds: definition of MDS_FEATURE_INCOMPAT_FILE_LAYOUT_V2 is wrong added

#6 Updated by Patrick Donnelly about 1 year ago

  • Status changed from Pending Backport to Resolved

#7 Updated by Nathan Cutler about 1 year ago

  • Related to Bug #23172: mds: fixed MDS_FEATURE_INCOMPAT_FILE_LAYOUT_V2 definition breaks luminous upgrades added

#8 Updated by Nathan Cutler about 1 year ago

@Yan, @Patrick - I checked and this affects jewel as well. The fix is problematic, though, because it causes MDSes to suicide. Is it better to not backport to jewel?

#9 Updated by Patrick Donnelly about 1 year ago

Yes, let's not backport to jewel.

Also available in: Atom PDF