Project

General

Profile

Bug #21907

On pg repair the primary is not favored as was intended

Added by David Zafman over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
10/24/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

The commit cd0d8b0 was supposed to favor the primary as the authoritative copy, but did the opposite.


Related issues

Related to Ceph - Bug #21328: Performance: Slow OSD startup, heavy LevelDB activity Resolved 09/08/2017
Copied to RADOS - Bug #22138: jewel: On pg repair the primary is not favored as was intended Won't Fix 10/24/2017
Copied to RADOS - Backport #22213: luminous: On pg repair the primary is not favored as was intended Resolved

History

#1 Updated by David Zafman over 1 year ago

  • Status changed from New to Pending Backport
  • Tags changed from luminous to jewel,luminous

#2 Updated by Nathan Cutler over 1 year ago

@David: Has this fix been merged to master? If so, can you point us to the PR or SHA1?

#3 Updated by David Zafman over 1 year ago

https://github.com/ceph/ceph/pull/18449

Backport all to Luminous and only these 3 out of 6 commits for Jewel:

0c106f1a46815bb769e7a503b1adb265480b6779
b7d2f27da1a68046a688749f95093a88e6362b28
1ad05b1068ddd5d3312af45af1a60587200ddcd7

#4 Updated by David Zafman over 1 year ago

  • Copied to Bug #22138: jewel: On pg repair the primary is not favored as was intended added

#5 Updated by David Zafman over 1 year ago

  • Related to Backport #21440: jewel: Performance: Slow OSD startup, heavy LevelDB activity added

#6 Updated by David Zafman over 1 year ago

  • Tags changed from jewel,luminous to luminous

Instead of backporting this to Jewel we only need one of the commits (1ad05b1068ddd5d3312af45af1a60587200ddcd7) so I'm adding to related http://tracker.ceph.com/issues/21440

#7 Updated by Nathan Cutler over 1 year ago

  • Tags deleted (luminous)
  • Backport set to luminous

#8 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #22213: luminous: On pg repair the primary is not favored as was intended added

#9 Updated by Nathan Cutler over 1 year ago

Just to recapitulate, the jewel backport was effected by cherry-picking a single commit - 1ad05b1068ddd5d3312af45af1a60587200ddcd7 - into https://github.com/ceph/ceph/pull/18951

#10 Updated by Nathan Cutler over 1 year ago

  • Related to deleted (Backport #21440: jewel: Performance: Slow OSD startup, heavy LevelDB activity)

#11 Updated by Nathan Cutler over 1 year ago

  • Related to Bug #21328: Performance: Slow OSD startup, heavy LevelDB activity added

#12 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF