Project

General

Profile

Bug #21860

Disable messenger logging (debug ms = 0/0) for clients unless overridden.

Added by Jason Dillaman about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
10/19/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Luminous is seeing a large performance drop due to expensive internal logging (for crash dumps). For clients like librbd, the value of the log messages is overshadowed by the >40% performance degradation when it's enabled.


Related issues

Copied to rbd - Backport #21918: luminous: Disable messenger logging (debug ms = 0/0) for clients unless overridden. Resolved

History

#1 Updated by Jason Dillaman about 2 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Sage Weil about 2 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler about 2 months ago

  • Copied to Backport #21918: luminous: Disable messenger logging (debug ms = 0/0) for clients unless overridden. added

#4 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF