Project

General

Profile

Bug #21423

qa: test_client_pin times out waiting for dentry release from kernel

Added by Patrick Donnelly over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Correctness/Safety
Target version:
-
Start date:
09/18/2017
Due date:
% Done:

0%

Source:
Support
Tags:
Backport:
luminous,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
fs
Component(FS):
ceph-fuse
Labels (FS):
Pull request ID:

Description

http://magna002.ceph.redhat.com/vasu-2017-09-16_00:44:06-fs-luminous---basic-multi/274192/teuthology.log

http://magna002.ceph.redhat.com/vasu-2017-09-16_00:44:06-fs-luminous---basic-multi/274192/remote/pluto008/log/ceph-client.0.341623.log

I've seen this problem before doing development of https://github.com/ceph/ceph/pull/17657. In that case I only saw the problem when ceph-fuse was unable to remount to trim dentries (as a regular user). Vasu is seeing this even with ceph-fuse as root.

BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1492865


Related issues

Related to fs - Bug #21426: qa/workunits/fs/snaps/untar_snap_rm.sh: timeout during up:rejoin (thrashing) New 09/18/2017
Duplicated by fs - Bug #24730: Client::_invalidate_kernel_dcache causes NFS lookup “deleted” dentry Duplicate 07/02/2018
Copied to fs - Backport #21486: luminous: qa: test_client_pin times out waiting for dentry release from kernel Resolved
Copied to fs - Backport #21519: jewel: qa: test_client_pin times out waiting for dentry release from kernel Resolved

History

#1 Updated by Zheng Yan over 1 year ago

  • Status changed from New to In Progress

The reason is that, when kerne verion < 3.18, ceph-fuse uses "dentry invalidate" upcall to trim dcache. but the patch set that make this method not work have been backpoerted into rhel 3.10 kernel.

I think the simplest fix is set client_try_dentry_invalidate=false by default.

#2 Updated by Zheng Yan over 1 year ago

  • Status changed from In Progress to Need Review

#3 Updated by Patrick Donnelly over 1 year ago

  • Related to Bug #21426: qa/workunits/fs/snaps/untar_snap_rm.sh: timeout during up:rejoin (thrashing) added

#4 Updated by Patrick Donnelly over 1 year ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #21486: luminous: qa: test_client_pin times out waiting for dentry release from kernel added

#6 Updated by Patrick Donnelly over 1 year ago

  • Backport changed from luminous to luminous,jewel

This is also a problem for RHCS 2.0, we need to backport to Jewel.

#7 Updated by Patrick Donnelly over 1 year ago

  • Copied to Backport #21519: jewel: qa: test_client_pin times out waiting for dentry release from kernel added

#8 Updated by Nathan Cutler about 1 year ago

  • Status changed from Pending Backport to Resolved

#9 Updated by Patrick Donnelly 9 months ago

  • Duplicated by Bug #24730: Client::_invalidate_kernel_dcache causes NFS lookup “deleted” dentry added

Also available in: Atom PDF