Project

General

Profile

Bug #21381

test_filtered_df: assert 0.9 < ratio < 1.1

Added by Patrick Donnelly 10 days ago. Updated about 19 hours ago.

Status:
Resolved
Priority:
Urgent
Category:
Testing
Target version:
-
Start date:
09/13/2017
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
fs
Release:
Component(FS):
Client
Needs Doc:
No

Description

2017-09-13T14:57:43.647 INFO:teuthology.orchestra.run.smithi135.stdout:
2017-09-13T14:57:43.647 INFO:teuthology.orchestra.run.smithi135.stdout:{
2017-09-13T14:57:43.647 INFO:teuthology.orchestra.run.smithi135.stdout:    "pool": "cephfs_data",
2017-09-13T14:57:43.647 INFO:teuthology.orchestra.run.smithi135.stdout:    "pool_id": 7,
2017-09-13T14:57:43.647 INFO:teuthology.orchestra.run.smithi135.stdout:    "size": 2
2017-09-13T14:57:43.647 INFO:teuthology.orchestra.run.smithi135.stdout:}
2017-09-13T14:57:43.648 INFO:teuthology.orchestra.run.smithi142:Running: 'cd /home/ubuntu/cephtest/mnt.0 && sudo df .'
2017-09-13T14:57:43.797 INFO:teuthology.orchestra.run.smithi142.stdout:Filesystem     1K-blocks  Used Available Use% Mounted on
2017-09-13T14:57:43.797 INFO:teuthology.orchestra.run.smithi142.stdout:ceph-fuse      132845568     0 132845568   0% /home/ubuntu/cephtest/mnt.0
2017-09-13T14:57:43.802 INFO:tasks.cephfs_test_runner:test_filtered_df (tasks.cephfs.test_misc.TestMisc) ... FAIL
...
2017-09-13T14:57:48.127 INFO:tasks.cephfs_test_runner:======================================================================
2017-09-13T14:57:48.127 INFO:tasks.cephfs_test_runner:FAIL: test_filtered_df (tasks.cephfs.test_misc.TestMisc)
2017-09-13T14:57:48.127 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2017-09-13T14:57:48.127 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2017-09-13T14:57:48.127 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/github.com_ceph_ceph_master/qa/tasks/cephfs/test_misc.py", line 151, in test_filtered_df
2017-09-13T14:57:48.127 INFO:tasks.cephfs_test_runner:    assert 0.9 < ratio < 1.1
2017-09-13T14:57:48.128 INFO:tasks.cephfs_test_runner:AssertionError
2017-09-13T14:57:48.128 INFO:tasks.cephfs_test_runner:
2017-09-13T14:57:48.128 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2017-09-13T14:57:48.128 INFO:tasks.cephfs_test_runner:Ran 2 tests in 979.297s

From: /ceph/teuthology-archive/pdonnell-2017-09-13_03:09:06-fs-master-testing-basic-smithi/1625905/teuthology.log


Related issues

Related to RADOS - Bug #21243: incorrect erasure-code space in command ceph df Pending Backport
Copied to fs - Backport #21437: luminous: test_filtered_df: assert 0.9 < ratio < 1.1 Resolved

History

#1 Updated by Douglas Fuller 10 days ago

  • Category set to Testing
  • Status changed from New to Need Review

#2 Updated by Patrick Donnelly 10 days ago

I think this was caused by:

commit 365558571c59dd42cf0934e6c31c7b4bf2c65026 365558571c (upstream/pull/17513/head)
Author: liuchang0812 <>
Date: Wed Sep 6 11:50:17 2017 +0800

mon: incorrect MAX AVAIL in "ceph df"
Fixes: http://tracker.ceph.com/issues/21243
Signed-off-by: liuchang0812 &lt;&gt;

#3 Updated by Patrick Donnelly 8 days ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Ken Dreyer 5 days ago

  • Related to Bug #21243: incorrect erasure-code space in command ceph df added

#5 Updated by Nathan Cutler 4 days ago

  • Copied to Backport #21437: luminous: test_filtered_df: assert 0.9 < ratio < 1.1 added

#6 Updated by Nathan Cutler about 19 hours ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF