Project

General

Profile

Bug #21378

mds: up:stopping MDS cannot export directories

Added by Patrick Donnelly 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
-
Category:
Correctness/Safety
Target version:
Start date:
09/13/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Component(FS):
Needs Doc:
No

Description

2017-09-13 01:37:19.607033 7fdaeb537700  7 mds.1.cache shutdown_pass
2017-09-13 01:37:19.607036 7fdaeb537700 10 mds.1.cache shutdown_export_strays
2017-09-13 01:37:19.607085 7fdaeb537700  7 mds.1.cache trim bytes_used=14kB limit=1GB reservation=0.05% count=18446744073709551615
2017-09-13 01:37:19.607099 7fdaeb537700  7 mds.1.cache trim_lru trimming 18446744073709551615 items from LRU size=2 mid=0 pintail=2 pinned=2
2017-09-13 01:37:19.607113 7fdaeb537700  7 mds.1.cache trim_lru trimmed 0 items
2017-09-13 01:37:19.607119 7fdaeb537700 20 mds.1.cache trim: maybe trimming base: [inode 0x1 [...2,head] / rep@0.2 v7 snaprealm=0x563cd491e080 f(v0 m2017-09-13 01:34:07.505302 2=0+2) n(v2 rc2017-09-13 01:34:31.353508 3=0+3)/n(v0 1=0+1) (inest mix) (iversion lock) | request=0 lock=0 dirfrag=1 caps=0 0x563cd4b42e00]
2017-09-13 01:37:19.607146 7fdaeb537700  5 mds.1.cache lru size now 2/2
2017-09-13 01:37:19.607149 7fdaeb537700  7 mds.1.cache looking for subtrees to export to mds0
2017-09-13 01:37:19.607154 7fdaeb537700  7 mds.1.cache sending [dir 0x10000000000 /dir_1/ [2,head] auth{0=2} v=11 cv=0/0 dir_auth=1 state=1611661314|complete|auxsubtree f(v1 m2017-09-13 01:34:31.353508) n(v1 rc2017-09-13 01:34:31.353508) hs=0+1,ss=0+0 dirty=1 | child=1 subtree=1 subtreetemp=0 replicated=1 dirty=1 waiter=0 authpin=0 0x563cd4b3bd40] back to mds.0
2017-09-13 01:37:19.607183 7fdaeb537700  7 mds.1.migrator export_dir_nicely [dir 0x10000000000 /dir_1/ [2,head] auth{0=2} v=11 cv=0/0 dir_auth=1 state=1611661314|complete|auxsubtree f(v1 m2017-09-13 01:34:31.353508) n(v1 rc2017-09-13 01:34:31.353508) hs=0+1,ss=0+0 dirty=1 | child=1 subtree=1 subtreetemp=0 replicated=1 dirty=1 waiter=0 authpin=0 0x563cd4b3bd40] to 0
2017-09-13 01:37:19.607206 7fdaeb537700  0 mds.1.migrator nicely exporting to mds.0 [dir 0x10000000000 /dir_1/ [2,head] auth{0=2} v=11 cv=0/0 dir_auth=1 state=1611661314|complete|auxsubtree f(v1 m2017-09-13 01:34:31.353508) n(v1 rc2017-09-13 01:34:31.353508) hs=0+1,ss=0+0 dirty=1 | child=1 subtree=1 subtreetemp=0 replicated=1 dirty=1 waiter=0 authpin=0 0x563cd4b3bd40]
2017-09-13 01:37:19.607226 7fdaeb537700  7 mds.1.migrator export_dir [dir 0x10000000000 /dir_1/ [2,head] auth{0=2} v=11 cv=0/0 dir_auth=1 state=1611661314|complete|auxsubtree f(v1 m2017-09-13 01:34:31.353508) n(v1 rc2017-09-13 01:34:31.353508) hs=0+1,ss=0+0 dirty=1 | child=1 subtree=1 subtreetemp=0 replicated=1 dirty=1 waiter=0 authpin=0 0x563cd4b3bd40] to 0
2017-09-13 01:37:19.607246 7fdaeb537700  7 mds.1.migrator i'm not active, no exports for now
2017-09-13 01:37:19.607250 7fdaeb537700  7 mds.1.cache still have 1 auth subtrees

From: /ceph/teuthology-archive/pdonnell-2017-09-13_00:06:25-fs-wip-pdonnell-testing-20170912-testing-basic-smithi/1624967/remote/smithi091/log/ceph-mds.b.log.gz

This is caused by: https://github.com/ceph/ceph/pull/17452
which fixes: http://tracker.ceph.com/issues/21222


Related issues

Related to fs - Bug #21222: MDS: standby-replay mds should avoid initiating subtree export Resolved 09/04/2017
Copied to fs - Backport #21385: luminous: mds: up:stopping MDS cannot export directories Resolved

History

#1 Updated by Patrick Donnelly 2 months ago

  • Related to Bug #21222: MDS: standby-replay mds should avoid initiating subtree export added

#2 Updated by Jianyu Li 2 months ago

Seems the check in export_dir is too strict for up:stopping state:

if (!mds->is_active()) {
dout(7) << "i'm not active, no exports for now" << dendl;
return;
}

for the original issue, it should be narrowed to standby-replay only, will fix it soon.

#3 Updated by Zheng Yan 2 months ago

  • Status changed from New to Need Review

#4 Updated by Jianyu Li 2 months ago

Looks good!

#5 Updated by Patrick Donnelly 2 months ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Patrick Donnelly 2 months ago

  • Copied to Backport #21385: luminous: mds: up:stopping MDS cannot export directories added

#7 Updated by Patrick Donnelly 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF