Project

General

Profile

Bug #21176

Build failure (in libboost_numpy?) when python-numpy-devel not installed in build environment

Added by Nathan Cutler 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
08/30/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Under circumstances that I don't yet understand (i.e. only in a certain build environment), the Ceph RPM build fails for SLES. The failure arises in the boost submodule phase of the build:

2017-08-30T07:21:07.557 DEBUG:teuthology.misc:In file included from libs/python/src/numpy/dtype.cpp:11:0:
2017-08-30T07:21:07.557 DEBUG:teuthology.misc:./boost/python/numpy/internal.hpp:28:31: fatal error: numpy/arrayobject.h: No such file or directory
2017-08-30T07:21:07.558 DEBUG:teuthology.misc:#include <numpy/arrayobject.h>
2017-08-30T07:21:07.558 DEBUG:teuthology.misc:^
2017-08-30T07:21:07.558 DEBUG:teuthology.misc:compilation terminated.
2017-08-30T07:21:08.196 DEBUG:teuthology.misc:In file included from libs/python/src/numpy/matrix.cpp:8:0:
2017-08-30T07:21:08.196 DEBUG:teuthology.misc:./boost/python/numpy/internal.hpp:28:31: fatal error: numpy/arrayobject.h: No such file or directory
2017-08-30T07:21:08.197 DEBUG:teuthology.misc:#include <numpy/arrayobject.h>
2017-08-30T07:21:08.197 DEBUG:teuthology.misc:^
2017-08-30T07:21:08.197 DEBUG:teuthology.misc:compilation terminated.
2017-08-30T07:21:08.333 DEBUG:teuthology.misc:[ 48%] Building CXX object CMakeFiles/rocksdb.dir/table/format.cc.o
2017-08-30T07:21:08.445 DEBUG:teuthology.misc:[ 48%] Building CXX object CMakeFiles/rocksdb.dir/table/full_filter_block.cc.o
2017-08-30T07:21:08.481 DEBUG:teuthology.misc:[ 51%] Building CXX object CMakeFiles/rocksdb.dir/table/get_context.cc.o
2017-08-30T07:21:08.485 DEBUG:teuthology.misc:[ 51%] Building CXX object CMakeFiles/rocksdb.dir/table/index_builder.cc.o
2017-08-30T07:21:08.553 DEBUG:teuthology.misc:[ 51%] Building CXX object CMakeFiles/rocksdb.dir/table/iterator.cc.o
2017-08-30T07:21:08.621 DEBUG:teuthology.misc:In file included from libs/python/src/numpy/ufunc.cpp:8:0:
2017-08-30T07:21:08.622 DEBUG:teuthology.misc:./boost/python/numpy/internal.hpp:28:31: fatal error: numpy/arrayobject.h: No such file or directory
2017-08-30T07:21:08.622 DEBUG:teuthology.misc:#include <numpy/arrayobject.h>
2017-08-30T07:21:08.622 DEBUG:teuthology.misc:^
2017-08-30T07:21:08.622 DEBUG:teuthology.misc:compilation terminated.
2017-08-30T07:21:08.822 DEBUG:teuthology.misc:In file included from libs/python/src/numpy/ndarray.cpp:8:0:
2017-08-30T07:21:08.823 DEBUG:teuthology.misc:./boost/python/numpy/internal.hpp:28:31: fatal error: numpy/arrayobject.h: No such file or directory
2017-08-30T07:21:08.823 DEBUG:teuthology.misc:#include <numpy/arrayobject.h>
2017-08-30T07:21:08.823 DEBUG:teuthology.misc:^
2017-08-30T07:21:08.824 DEBUG:teuthology.misc:compilation terminated.
2017-08-30T07:21:08.885 DEBUG:teuthology.misc:[ 51%] Building CXX object CMakeFiles/rocksdb.dir/table/merging_iterator.cc.o
2017-08-30T07:21:08.937 DEBUG:teuthology.misc:In file included from libs/python/src/numpy/numpy.cpp:8:0:
2017-08-30T07:21:08.938 DEBUG:teuthology.misc:./boost/python/numpy/internal.hpp:28:31: fatal error: numpy/arrayobject.h: No such file or directory
2017-08-30T07:21:08.938 DEBUG:teuthology.misc:#include <numpy/arrayobject.h>
2017-08-30T07:21:08.938 DEBUG:teuthology.misc:^
2017-08-30T07:21:08.939 DEBUG:teuthology.misc:compilation terminated.
2017-08-30T07:21:09.142 DEBUG:teuthology.misc:In file included from libs/python/src/numpy/scalars.cpp:8:0:
2017-08-30T07:21:09.142 DEBUG:teuthology.misc:./boost/python/numpy/internal.hpp:28:31: fatal error: numpy/arrayobject.h: No such file or directory
2017-08-30T07:21:09.143 DEBUG:teuthology.misc:#include <numpy/arrayobject.h>
2017-08-30T07:21:09.143 DEBUG:teuthology.misc:^
2017-08-30T07:21:09.143 DEBUG:teuthology.misc:compilation terminated.
2017-08-30T07:21:09.259 DEBUG:teuthology.misc:...skipped <pbin.v2/libs/python/build/gcc-4.8/release/link-static/threading-multi>libboost_numpy.a(clean) for lack of <pbin.v2/libs/python/build/gcc-4.8/release/link-static/threading-multi>numpy/dtype.o...
2017-08-30T07:21:09.260 DEBUG:teuthology.misc:...skipped <pbin.v2/libs/python/build/gcc-4.8/release/link-static/threading-multi>libboost_numpy.a for lack of <pbin.v2/libs/python/build/gcc-4.8/release/link-static/threading-multi>numpy/dtype.o...
2017-08-30T07:21:09.260 DEBUG:teuthology.misc:...skipped <pstage/lib>libboost_numpy.a for lack of <pbin.v2/libs/python/build/gcc-4.8/release/link-static/threading-multi>libboost_numpy.a...

When I add "BuildRequires: python-numpy-devel" the error goes away.

Since this is a relatively innocuous addition to the spec file which should not hurt environments that (for some unknown reason) do not need the change, I'll propose to add this build dependency for all SUSE builds.

History

#1 Updated by Nathan Cutler 3 months ago

  • Description updated (diff)

#2 Updated by Nathan Cutler 3 months ago

  • Status changed from New to Need Review

#3 Updated by Sage Weil about 2 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF