Project

General

Profile

Bug #20915

ceph-volume packaging thinks it owns ceph_volume_client.py

Added by Nathan Cutler 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
-
Category:
-
Target version:
-
Start date:
08/04/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

The recently merged ceph-volume PR introduces the following line to the spec file under "%files base"

%{python_sitelib}/ceph_volume*

This has the unfortunate side effect of causing src/pybind/ceph_volume_client.py to be included in both ceph-base and python-cephfs. (Note: this file has been living in python-cephfs for years)

One solution would be to replace "ceph_volume*" with a taxative list of files that ceph-volume needs to work correctly.

Setting priority to Immediate because this breaks the RPM packaging of ceph as a whole.

History

#1 Updated by Sage Weil 3 months ago

I think the debian/ceph-osd.install has a copy-pasto:

usr/lib/python*/dist-packages/ceph_disk*
usr/sbin/ceph-disk
usr/sbin/ceph-volume
usr/lib/python*/dist-packages/ceph_disk*

guessing the second pne was meant to be ceph_volume*.

#2 Updated by Sage Weil 3 months ago

  • Status changed from New to Testing

#3 Updated by Sage Weil 2 months ago

  • Status changed from Testing to Resolved

Also available in: Atom PDF