Project

General

Profile

Bug #20850

osd: luminous osd crashes when older monitor doesn't support set-device-class

Added by Josh Durgin 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
-
Category:
Correctness/Safety
Target version:
-
Start date:
07/28/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No
Component(RADOS):

Description

See e.g.:

http://pulpito.ceph.com/joshd-2017-07-28_23:13:34-upgrade:jewel-x-master-distro-basic-smithi/1456505/

If we get anything other than EPERM, the osd crashes. Perhaps this should be gated on the require_luminous_osds flag.

History

#1 Updated by Sage Weil 4 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF