Project

General

Profile

Bug #20767

Zabbix plugin assumes legacy compat mode for health json

Added by Fabien Brachere 26 days ago. Updated 25 days ago.

Status:
Resolved
Priority:
Immediate
Assignee:
-
Category:
-
Target version:
Start date:
07/25/2017
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Zabbix ceph mgr plugin is broken and fire an error when you try to send data manually:

# ceph tell mgr zabbix send
Error EINVAL: Traceback (most recent call last):
  File "/usr/lib64/ceph/mgr/zabbix/module.py", line 232, in handle_command
    self.send()
  File "/usr/lib64/ceph/mgr/zabbix/module.py", line 204, in send
    data = self.get_data()
  File "/usr/lib64/ceph/mgr/zabbix/module.py", line 116, in get_data
    data['overall_status'] = health['overall_status']
KeyError: ('overall_status',)

It seems that Key "overall_status" doesn't exist anymore, I changed "overall_status" by "status" in file /usr/lib64/ceph/mgr/zabbix/module.py and the problem was solved.

Ceph version tested:

# ceph -v
ceph version 12.1.1 (f3e663a190bf2ed12c7e3cda288b9a159572c800) luminous (rc)

mgr version:

# rpm -qi ceph-mgr
Name        : ceph-mgr
Epoch       : 2
Version     : 12.1.1
Release     : 0.el7
Architecture: x86_64
Install Date: dim. 23 juil. 2017 09:56:27 CEST
Group       : Unspecified
Size        : 28413376
License     : LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and BSD-3-Clause and MIT
Signature   : (none)
Source RPM  : ceph-12.1.1-0.el7.src.rpm
Build Date  : mar. 18 juil. 2017 13:57:51 CEST
Build Host  : slave-centos05
Relocations : (not relocatable)
URL         : http://ceph.com/
Summary     : Ceph Manager Daemon

History

#1 Updated by Sage Weil 26 days ago

  • Subject changed from Zabbix plugin to Zabbix plugin assumes legacy compat mode for health json
  • Status changed from New to Verified
  • Priority changed from Normal to Immediate

#2 Updated by Sage Weil 26 days ago

  • Status changed from Verified to Need Review

#3 Updated by Sage Weil 25 days ago

  • Status changed from Need Review to Resolved

Please retest with latest master and let us know if there are still problems!

#4 Updated by Fabien Brachere 25 days ago

Tested with 35f096e

# ceph -v
ceph version 12.1.1-628-g35f096e (35f096ed190c08fec4ecb3346611b03682eafed2) luminous (rc)

The bug is solved, thank you.

Also available in: Atom PDF