Project

General

Profile

Bug #20602

mon crush smoke test can time out under valgrind

Added by Sage Weil over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
-
Start date:
07/12/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

/a/sage-2017-07-12_02:32:14-rados-wip-sage-testing-distro-basic-smithi/1390174
rados/singleton-nomsgr/{all/valgrind-leaks.yaml rados.yaml}

2017-07-12T04:43:04.869 INFO:tasks.ceph:Creating RBD pool
2017-07-12T04:43:04.869 INFO:teuthology.orchestra.run.smithi033:Running: 'sudo ceph --cluster ceph osd pool create rbd 8'
2017-07-12T04:43:10.553 INFO:tasks.ceph.mon.a.smithi033.stderr:: timed out (5 sec)
2017-07-12T04:43:13.512 INFO:teuthology.orchestra.run.smithi033.stderr:Error ETIMEDOUT: crush test failed with -110: timed out during smoke test (5 seconds)

Related issues

Related to RADOS - Bug #20601: mon comamnds time out due to pool create backlog w/ valgrind Duplicate 07/12/2017

History

#1 Updated by Sage Weil over 1 year ago

  • Description updated (diff)

#2 Updated by Sage Weil over 1 year ago

  • Priority changed from High to Urgent

/a/sage-2017-07-12_19:30:01-rados-wip-sage-testing-distro-basic-smithi/1392270
rados/singleton-nomsgr/{all/valgrind-leaks.yaml rados.yaml}

pretty reproducible, it seems!

#3 Updated by Sage Weil over 1 year ago

  • Priority changed from Urgent to Immediate

/a/sage-2017-07-13_20:38:15-rados-wip-sage-testing-distro-basic-smithi/1397207

that's two consecutive runs for me..

#4 Updated by Kefu Chai over 1 year ago

/a/kchai-2017-07-13_18:13:10-rados-wip-kefu-testing-distro-basic-smithi/1396642

rados/singleton-nomsgr/{all/valgrind-leaks.yaml rados.yaml}

#5 Updated by Sage Weil over 1 year ago

A simple workaround would be to make a 'mon smoke test crush changes' option and turn it off when using valgrind.. what do you think?

#6 Updated by Sage Weil over 1 year ago

  • Related to Bug #20601: mon comamnds time out due to pool create backlog w/ valgrind added

#7 Updated by Sage Weil over 1 year ago

Valgrind is slow to do the fork and cleanup; that's why we keep timing out. Blame e189f11fcde6829cc7f86894b913bc1a3f81ecfe

#8 Updated by Sage Weil over 1 year ago

Valgrind is slow to do the fork and cleanup; that's why we keep timing out. Blame e189f11fcde6829cc7f86894b913bc1a3f81ecfe

https://github.com/ceph/ceph/pull/16346

#9 Updated by Sage Weil over 1 year ago

  • Status changed from Verified to Need Review

#10 Updated by Kefu Chai over 1 year ago

  • Status changed from Need Review to Resolved
  • Assignee set to Sage Weil

Also available in: Atom PDF