Project

General

Profile

Bug #20544

Bad status warning for mon_warn_osd_usage_min_max_delta

Added by David Zafman 4 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Monitor
Target version:
-
Start date:
07/07/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Message on LRC cluster:

difference between min (4.57%) and max (8.58%) osd usage 4.01% > 4 (mon_warn_osd_usage_min_max_delta)

should read:

difference between min (45.7%) and max (85.8%) osd usage 40.1% > 40% (mon_warn_osd_usage_min_max_delta)


Related issues

Copied to Ceph - Backport #20672: kraken: Bad status warning for mon_warn_osd_usage_min_max_delta Resolved
Copied to Ceph - Backport #20676: jewel: Bad status warning for mon_warn_osd_usage_min_max_delta Resolved

History

#1 Updated by David Zafman 4 months ago

Caused by 489e810c37ed6fb9d32d1015634041a577501ee4

#2 Updated by David Zafman 4 months ago

https://github.com/ceph/ceph/pull/16220

This change should be back ported.

#3 Updated by David Zafman 4 months ago

  • Status changed from New to Need Review

#4 Updated by Sage Weil 4 months ago

  • Status changed from Need Review to Resolved

#5 Updated by Nathan Cutler 3 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to kraken

#6 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #20672: kraken: Bad status warning for mon_warn_osd_usage_min_max_delta added

#7 Updated by Nathan Cutler 3 months ago

  • Backport changed from kraken to kraken,jewel

#8 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #20676: jewel: Bad status warning for mon_warn_osd_usage_min_max_delta added

#9 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF