Project

General

Profile

Bug #20524

src/common/Mutex.cc: 109: FAILED assert(r == 0)

Added by Kefu Chai over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
-
Start date:
07/06/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

 ceph version 12.0.3-2564-g0805115 (08051155a4e09b75649d59edc16d069119cc0d6e) luminous (rc)
 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x110) [0xb36100]
 2: (Mutex::Lock(bool)+0x1a4) [0xb169e4]
 3: (FileStore::_journaled_ahead(FileStore::OpSequencer*, FileStore::Op*, Context*)+0x14a) [0x90118a]
 4: (Context::complete(int)+0x9) [0x607fb9]
 5: (Finisher::finisher_thread_entry()+0x198) [0xb33a58]
 6: (()+0x7dc5) [0xc7e4dc5]
 7: (clone()+0x6d) [0xd72b76d]

History

#1 Updated by Kefu Chai over 1 year ago

looks like a regression introduced by https://github.com/ceph/ceph/pull/13918

#2 Updated by Kefu Chai over 1 year ago

  • Status changed from New to Need Review
  • Assignee set to Kefu Chai

#3 Updated by Kefu Chai over 1 year ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF