Project

General

Profile

Bug #20471

Can't repair corrupt object info due to bad oid on all replicas

Added by David Zafman over 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Scrub/Repair
Target version:
-
Start date:
06/30/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

We detect a kind of corruption where the oid in the object info doesn't match the oid of the object. This was added at the request of http://tracker.ceph.com/issues/18409 in commit 9614ab556ca8e4e5daec1e71d9b6032633ba21a0.

I didn't anticipate the case where all versions of the object info have the same error. This would make it unrepairable.

According to Sam: "This came up on the sepia cluster due (presumably) to an xfs bug in the murky past." Assuming that this is caused by a bug in older bfs code we could add code to fix the object info and move on.


Related issues

Copied to RADOS - Backport #23181: jewel: Can't repair corrupt object info due to bad oid on all replicas Resolved

History

#1 Updated by David Zafman over 1 year ago

  • Status changed from Verified to In Progress
2017-06-30 15:55:46.845656 osd.1 [INF] 1.6 scrub starts
2017-06-30 15:55:46.847427 osd.0 [ERR] osd.0 found object info error on pg 1.6 oid 1:602f83fe:::foo:head oid in object info: 1:602f83fe:::boo:head...repaired
2017-06-30 15:55:46.847427 osd.1 [ERR] osd.1 found object info error on pg 1.6 oid 1:602f83fe:::foo:head oid in object info: 1:602f83fe:::boo:head...repaired
2017-06-30 15:55:46.847433 osd.2 [ERR] osd.2 found object info error on pg 1.6 oid 1:602f83fe:::foo:head oid in object info: 1:602f83fe:::boo:head...repaired
2017-06-30 15:55:46.849443 osd.1 [INF] 1.6 scrub ok

#2 Updated by David Zafman over 1 year ago

  • Status changed from In Progress to Need Review

#3 Updated by Sage Weil over 1 year ago

  • Status changed from Need Review to Testing

#4 Updated by Sage Weil over 1 year ago

  • Status changed from Testing to Resolved

#5 Updated by Nathan Cutler 9 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to jewel

#6 Updated by Nathan Cutler 9 months ago

  • Copied to Backport #23181: jewel: Can't repair corrupt object info due to bad oid on all replicas added

#7 Updated by Nathan Cutler 8 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF