Project

General

Profile

Backport #20412

test_remote_update_write (tasks.cephfs.test_quota.TestQuota) fails in Jewel 10.2.8 integration testing

Added by Nathan Cutler 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Target version:
Release:
jewel

History

#1 Updated by Nathan Cutler 3 months ago

  • Description updated (diff)

#2 Updated by Patrick Donnelly 3 months ago

  • Status changed from New to In Progress
  • Assignee set to Patrick Donnelly

I dug into the logs. It looks like the MDS is not sending a quota update to the client. From a brief look at the code, it appears the quota updates are only broadcast for parents of the updated inode:

https://github.com/ceph/ceph/blob/7f5bd004b35e2a1b60f4951e8a70646f0ad08b3f/src/mds/MDCache.cc#L2078

I'm not sure I see how this ever worked. I'll do more testing.

#3 Updated by John Spray 3 months ago

Aargh, I think this might just be failing because this is a new test that was written for luminous, where client_quota is true by default -- this might pass on jewel if we update the test config to set client_quota (borrow the override from cfuse_workunit_quota.yaml into quota.yaml)

#4 Updated by Patrick Donnelly 3 months ago

  • Status changed from In Progress to Need Review

John, that looks like the problem. Here's a PR:

https://github.com/ceph/ceph/pull/15936

#6 Updated by Patrick Donnelly 3 months ago

  • Status changed from Need Review to Resolved

#7 Updated by Nathan Cutler 2 months ago

  • Tracker changed from Bug to Backport
  • Description updated (diff)
  • Priority changed from High to Normal
  • Target version set to v10.2.8
  • Release jewel added

description

This test fails reproducibly on the wip-jewel-backports branch: fs/recovery/{clusters/4-remote-clients.yaml debug/mds_client.yaml dirfrag/frag_enable.yaml mounts/ceph-fuse.yaml tasks/quota.yaml xfs.yaml}

Test Run: smithfarm-2017-06-25_07:23:04-fs-wip-jewel-backports-distro-basic-smithi

info: http://pulpito.ceph.com/smithfarm-2017-06-25_07:23:04-fs-wip-jewel-backports-distro-basic-smithi/
logs: http://qa-proxy.ceph.com/teuthology/smithfarm-2017-06-25_07:23:04-fs-wip-jewel-backports-distro-basic-smithi/

Log of failing test: http://qa-proxy.ceph.com/teuthology/smithfarm-2017-06-25_07:23:04-fs-wip-jewel-backports-distro-basic-smithi/1324503/teuthology.log

The failure emanates from these lines: https://github.com/ceph/ceph/blob/jewel/qa/tasks/cephfs/test_quota.py#L100-L103

Also available in: Atom PDF