Project

General

Profile

Bug #20368

rados/upgrade rgw swift test fails

Added by Sage Weil over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Target version:
-
Start date:
06/21/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:======================================================================
2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:ERROR: test_get_range (test.functional.tests.TestDlo)
2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:----------------------------------------------------------------------
2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:Traceback (most recent call last):
2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:  File "/home/ubuntu/cephtest/swift/test/functional/tests.py", line 1513, in test_get_range
2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:    file_contents = file_item.read(size=1, offset=47)
2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:  File "/home/ubuntu/cephtest/swift/test/functional/swift.py", line 611, in read
2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:    raise ResponseError(self.conn.response)
2017-06-21T05:14:37.124 INFO:teuthology.orchestra.run.smithi059.stderr:ResponseError: 416: Requested Range Not Satisfiable
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:======================================================================
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:ERROR: test_get_range (test.functional.tests.TestDloUTF8)
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:----------------------------------------------------------------------
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:Traceback (most recent call last):
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:  File "/home/ubuntu/cephtest/swift/test/functional/tests.py", line 1513, in test_get_range
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:    file_contents = file_item.read(size=1, offset=47)
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:  File "/home/ubuntu/cephtest/swift/test/functional/swift.py", line 611, in read
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:    raise ResponseError(self.conn.response)
2017-06-21T05:14:37.125 INFO:teuthology.orchestra.run.smithi059.stderr:ResponseError: 416: Requested Range Not Satisfiable
2017-06-21T05:14:37.126 INFO:teuthology.orchestra.run.smithi059.stderr:
2017-06-21T05:14:37.126 INFO:teuthology.orchestra.run.smithi059.stderr:----------------------------------------------------------------------

/a/sage-2017-06-21_02:01:04-rados-wip-sage-testing2-distro-basic-smithi/1307885

seems to have started yesterday


Related issues

Related to rgw - Bug #20373: "test_get_manifest (test.functional.tests.TestDlo)*" failed in rgw Need More Info 06/21/2017
Related to Ceph - Tasks #20392: Move swift.py task from ceph/teuthology.git into ceph/ceph.git Resolved 06/23/2017
Copied to rgw - Backport #20520: kraken: rados/upgrade rgw swift test fails Resolved

History

#1 Updated by Casey Bodley over 1 year ago

  • Assignee set to Casey Bodley

oops. updated swift tests for slo/dlo merged before the pr:

https://github.com/ceph/ceph/pull/15060

#2 Updated by Casey Bodley over 1 year ago

  • Related to Bug #20373: "test_get_manifest (test.functional.tests.TestDlo)*" failed in rgw added

#3 Updated by Casey Bodley over 1 year ago

  • Priority changed from Immediate to High

pr merged to master. will resolve when we see a clean run. lowering priority for now

#4 Updated by Casey Bodley over 1 year ago

  • Related to Tasks #20392: Move swift.py task from ceph/teuthology.git into ceph/ceph.git added

#5 Updated by Sage Weil over 1 year ago

  • Priority changed from High to Immediate

#6 Updated by Sage Weil over 1 year ago

This still fails every time. Latest:

/a/sage-2017-07-01_06:55:28-rados-wip-sage-testing2-distro-basic-smithi/1351214

rados/upgrade/jewel-x-singleton/{0-cluster/{openstack.yaml start.yaml} 1-jewel-install/jewel.yaml 2-partial-upgrade/firsthalf.yaml 3-thrash/default.yaml 4-workload/{rbd-cls.yaml rbd-import-export.yaml readwrite.yaml snaps-few-objects.yaml} 5-workload/{radosbench.yaml rbd_api.yaml} 6-finish-upgrade.yaml 7-luminous.yaml 8-workload/{rbd-python.yaml rgw-swift.yaml snaps-many-objects.yaml}}

#9 Updated by Kefu Chai over 1 year ago

/a/kchai-2017-07-05_03:23:34-rados-wip-kefu-testing-distro-basic-mira/1362323

#10 Updated by Yehuda Sadeh over 1 year ago

Looking at the current failures, it's all happening when testing kraken (directly, or when doing an upgrade test). Currently there's no way to specify the version to test against in the swift suite as we have with the s3 test suite. This will be fixed, but in the mean time we'll backport the fix to the original problem to kraken (and potentially jewel).

#12 Updated by Nathan Cutler over 1 year ago

  • Status changed from Verified to Pending Backport
  • Backport set to kraken

@Yehuda: Thanks! Jewel already has a workaround in place, so kraken backport is sufficient I guess.

#13 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #20520: kraken: rados/upgrade rgw swift test fails added

#14 Updated by Nathan Cutler over 1 year ago

Oops, the kraken backport is non-trivial.

#15 Updated by Casey Bodley over 1 year ago

Nathan Cutler wrote:

@Yehuda: Thanks! Jewel already has a workaround in place, so kraken backport is sufficient I guess.

The workaround for jewel is to run against the ceph-jewel branch of swift tests, correct? What still needs to be done for kraken?

#16 Updated by Nathan Cutler over 1 year ago

@Casey: Yes, jewel has a patched swift.py that simply (hard-coded) checks out the ceph-jewel branch. I have applied a similar patch to the kraken integration branch, which enabled me to get a clean rgw run. In the meantime, Matt opened https://github.com/ceph/ceph/pull/16129 but I think it has a build error.

As Yehuda said, proper fixes for both kraken and jewel are needed, because some of the upgrade tests in master run swift.py on the stable branches.

#17 Updated by Nathan Cutler over 1 year ago

#18 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Need Review

#19 Updated by Nathan Cutler over 1 year ago

  • Status changed from Need Review to Pending Backport

#20 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF