Project

General

Profile

Bug #20258

mgr: pecan error from restful module (trusty)

Added by Sage Weil over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
-
Start date:
06/12/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

/a/sage-2017-06-12_16:22:35-rados-master---basic-smithi/1280052

2017-06-12 16:34:29.815205 7f2e0d7ae700  0 mgr[restful] Traceback (most recent call last):
  File "/usr/lib/ceph/mgr/restful/module.py", line 233, in serve
    self._serve()
  File "/usr/lib/ceph/mgr/restful/module.py", line 288, in _serve
    hooks = lambda: [ErrorHook()],
  File "/usr/lib/python2.7/dist-packages/pecan/__init__.py", line 72, in make_app
    app = Pecan(root, **kw)
  File "/usr/lib/python2.7/dist-packages/pecan/core.py", line 211, in __init__
    key=operator.attrgetter('priority')
TypeError: 'function' object is not iterable

History

#1 Updated by Kefu Chai over 1 year ago

  • Status changed from New to Verified
  • Assignee set to Kefu Chai

#2 Updated by Kefu Chai over 1 year ago

  • Status changed from Verified to Need Review

#3 Updated by Sage Weil over 1 year ago

on master we fail because of something else, which this fixes:

https://github.com/ceph/ceph/pull/15695 (closed in favor of https://github.com/ceph/ceph/pull/15646)

#4 Updated by Kefu Chai over 1 year ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF