Project

General

Profile

Bug #20229

ceph-disk systemd unit timesout too quickly

Added by Loic Dachary 5 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
06/08/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

When there are more than a few disks, it is likely to take longer than five minutes.

http://tracker.ceph.com/issues/18060 proposed to reduce the lock contention but it does not really help because there is another global lock within ceph-disk right after that. It effectively is a noop.

http://tracker.ceph.com/issues/18740 is a better workaround because it allows to configure the timeout without modifying the systemd unit.

It would be simpler and have no undesirable side effect to just set the timeout to a very large value. There needs to be a timeout to prevent ceph-disk from hanging forever (that was the first incentive to set a timeout). But there is no good reason to set it to a value that is less than a few hours.


Related issues

Copied to Ceph - Backport #21035: jewel: ceph-disk systemd unit timesout too quickly Resolved

History

#1 Updated by Loic Dachary 5 months ago

  • Status changed from Verified to Need Review

#2 Updated by Sage Weil 4 months ago

  • Status changed from Need Review to Testing

#3 Updated by Sage Weil 4 months ago

  • Status changed from Testing to Resolved

#4 Updated by Nathan Cutler 2 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to jewel

#5 Updated by Nathan Cutler 2 months ago

  • Copied to Backport #21035: jewel: ceph-disk systemd unit timesout too quickly added

#6 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF