Project

General

Profile

Bug #20135

test/rest.py: PUT auth/add?entity=client.xx&caps=mon&caps=allow&caps=osd&caps=allow+*: json 400

Added by Sage Weil about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
-
Category:
-
Target version:
-
Start date:
06/01/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

2017-06-02T02:46:56.574 INFO:tasks.workunit.client.0.smithi044.stderr:Headers:  CaseInsensitiveDict({'date': 'Fri, 02 Jun 2017 02:46:56 GMT', 'content-length': '78', 'content-type': 'text/html; charset=utf-8', 'server': 'Werkzeug/0.9.4 Python/2.7.6'})
2017-06-02T02:46:56.574 INFO:tasks.workunit.client.0.smithi044.stdout:GET auth/export: plain 200
2017-06-02T02:46:56.575 INFO:tasks.workunit.client.0.smithi044.stdout:GET auth/export.json: json 200
2017-06-02T02:46:56.575 INFO:tasks.workunit.client.0.smithi044.stdout:GET auth/export.xml: xml 200
2017-06-02T02:46:56.575 INFO:tasks.workunit.client.0.smithi044.stdout:GET auth/export: json 200
2017-06-02T02:46:56.575 INFO:tasks.workunit.client.0.smithi044.stdout:GET auth/export: xml 200
2017-06-02T02:46:56.576 INFO:tasks.workunit.client.0.smithi044.stdout:PUT auth/add?entity=client.xx&caps=mon&caps=allow&caps=osd&caps=allow+*: json 400

/a/sage-2017-06-02_02:40:02-rados-master-distro-basic-smithi/1254732

this is very recent...

History

#1 Updated by Kefu Chai about 2 months ago

http://pulpito.ceph.com/kchai-2017-06-02_09:03:21-rados-master---basic-smithi/

2017-06-02 07:35:24.583046 7fe3d7e25700  1 -- 172.21.15.183:6790/0 <== client.4150 172.21.15.183:0/3978186337 15 ==== mon_command({"prefix": "auth add", "module": "auth", "format": "json", "entity": "client.xx", "perm": "rwx", "caps": ["mon", "allow", "osd", "allow *", []]} v 0) v1 ==== 186+0+0 (611084259 0 0) 0x5604bbf5cf40 con 0x5604bc77a000
2017-06-02 07:35:24.583074 7fe3d7e25700 20 mon.b@1(peon) e1 _ms_dispatch existing session 0x5604bc7469c0 for client.? 172.21.15.183:0/3978186337
2017-06-02 07:35:24.583079 7fe3d7e25700 20 mon.b@1(peon) e1  caps allow *
2017-06-02 07:35:24.583160 7fe3d7e25700  2 mon.b@1(peon) e1 send_reply 0x5604bbc8a8c0 0x5604bc058580 mon_command_ack([{"prefix": "auth add", "module": "auth", "format": "json", "entity": "client.xx", "perm": "rwx", "caps": ["mon", "allow", "osd", "allow *", []]}]=-22 Can't handle arrays of multiple types v0) v1
2017-06-02 07:35:24.583168 7fe3d7e25700  1 -- 172.21.15.183:6790/0 --> 172.21.15.183:0/3978186337 -- mon_command_ack([{"prefix": "auth add", "module": "auth", "format": "json", "entity": "client.xx", "perm": "rwx", "caps": ["mon", "allow", "osd", "allow *", []]}]=-22 Can't handle arrays of multiple types v0) v1 -- 0x5604bc058580 con 0

mon log

#2 Updated by Kefu Chai about 2 months ago

i cannot reproduce this locally =(

#3 Updated by Sage Weil about 2 months ago

  • Status changed from New to Need Review

#4 Updated by Sage Weil about 2 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF