Project

General

Profile

Bug #20131

mds/MDBalancer: update MDSRank export_targets according to current balance state

Added by Zhi Zhang about 2 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/01/2017
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
multimds
Pull request ID:

Description

I think this might be a regression issue introduced by https://github.com/ceph/ceph/commit/082e86c58f5abb93e2a912e603d86f12bc47972c. We didn't see such issue in Jewel when trying to use old balancer.

The reason should be that currently MDS's export_targets in MDSMap are empty even if they need to do rebalance because we didn't update MDSRank's export_targets according to balance state, then MDSRank's tick won't update MDSMap's export_targets to Mon.

And the new function MDBalancer::hit_targets should be aimed to do such things, but it hadn't been called at anywhere.

History

#2 Updated by John Spray about 2 years ago

  • Status changed from New to Need Review

#3 Updated by John Spray almost 2 years ago

  • Status changed from Need Review to Resolved

#4 Updated by Patrick Donnelly 3 months ago

  • Category deleted (90)
  • Labels (FS) multimds added

Also available in: Atom PDF