Project

General

Profile

Bug #20106

Rename of assembler source code file from .S to .s breaks ppc64le build

Added by Nathan Cutler 4 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/30/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

https://github.com/ceph/ceph/pull/15142 breaks the ppc64le build.

[ 1109s] [ 50%] Building ASM object src/CMakeFiles/common-objs.dir/common/crc32c_ppc_asm.s.o
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s: Assembler messages:
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:84: Error: unrecognized opcode: `func_start(__crc32_vpmsum)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:127: Error: unrecognized opcode: `mtvrd(v8,'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:200: Error: unrecognized opcode: `vperm(v16,v16,v16,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:201: Error: unrecognized opcode: `vperm(v17,v17,v17,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:204: Error: unrecognized opcode: `vperm(v18,v18,v18,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:205: Error: unrecognized opcode: `vperm(v19,v19,v19,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:208: Error: unrecognized opcode: `vperm(v20,v20,v20,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:209: Error: unrecognized opcode: `vperm(v21,v21,v21,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:212: Error: unrecognized opcode: `vperm(v22,v22,v22,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:213: Error: unrecognized opcode: `vperm(v23,v23,v23,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:225: Error: unrecognized opcode: `vpmsumd(v8,v16,const1)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:227: Error: unrecognized opcode: `vperm(v16,v16,v16,byteswap)'
[ 1109s] /home/abuild/rpmbuild/BUILD/ceph-12.0.3+git.1496067489.38e20fa173/src/common/crc32c_ppc_asm.s:230: Error: unrecognized opcode: `vpmsumd(v9,v17,const1)'
(many, many more messages like this)

The reason is that the filename change from .S (uppercase) to .s causes gcc to not run the preprocessor. See https://gcc.gnu.org/onlinedocs/gcc/Overall-Options.html (search for "sx").


Related issues

Duplicated by Ceph - Bug #20109: src/common/crc32c_ppc_asm.s ppc64le build break Resolved 05/30/2017

History

#1 Updated by Nathan Cutler 4 months ago

  • Description updated (diff)

#2 Updated by Nathan Cutler 4 months ago

  • Status changed from New to Need Review

#3 Updated by Nathan Cutler 4 months ago

  • Subject changed from Rename of assembler source code files from .S to .s breaks ppc64le build to Rename of assembler source code file from .S to .s breaks ppc64le build

#4 Updated by Nathan Cutler 4 months ago

  • Duplicated by Bug #20109: src/common/crc32c_ppc_asm.s ppc64le build break added

#5 Updated by Kefu Chai 4 months ago

  • Status changed from Need Review to Resolved

#6 Updated by Kefu Chai 4 months ago

  • Status changed from Resolved to Verified

#7 Updated by Nathan Cutler 4 months ago

  • Status changed from Verified to Duplicate

Also available in: Atom PDF