Project

General

Profile

Bug #19996

infinit loops in filestore::fiemap()

Added by Yao Ning 5 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
05/20/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
jewel
Needs Doc:
No

Description

since fiemap can get extents based on offset --> len
but we should consider last extents is retrieved when len == 0
even though it is not last fiemap extents

Fixed in master by https://github.com/ceph/ceph/pull/14367


Related issues

Copied to Ceph - Backport #20002: jewel: infinit loops in filestore::fiemap() Resolved

History

#1 Updated by Nathan Cutler 5 months ago

  • Description updated (diff)
  • Status changed from New to Pending Backport
  • Backport set to jewel

#2 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #20002: jewel: infinit loops in filestore::fiemap() added

#3 Updated by Nathan Cutler 5 months ago

  • Assignee set to Yao Ning

#4 Updated by Nathan Cutler about 1 month ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF