Project

General

Profile

Bug #19971

osd: deletes are performed inline during pg log processing

Added by Josh Durgin about 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Peering
Target version:
-
Start date:
05/17/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
OSD

Description

With a large number of deletes in a client workload, this can easily saturate a disk and cause very high latency, since it does not go through the op queue or do any batching.

To fix this, make recovery handle these deletes instead of performing them during peering.


Related issues

Copied to RADOS - Backport #22406: jewel: osd: deletes are performed inline during pg log processing Rejected

History

#1 Updated by Josh Durgin about 1 year ago

  • Status changed from New to In Progress

#2 Updated by Greg Farnum about 1 year ago

  • Project changed from Ceph to RADOS
  • Category set to Peering
  • Component(RADOS) OSD added

#4 Updated by Josh Durgin about 1 year ago

  • Status changed from In Progress to Resolved

#5 Updated by Ken Dreyer 7 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to jewel

#6 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #22406: jewel: osd: deletes are performed inline during pg log processing added

#7 Updated by Nathan Cutler about 1 month ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF