Project

General

Profile

Bug #19907

rbd-mirror: admin socket path names collision

Added by Mykola Golub 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
05/11/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

For every pool replayer rbd-mirror initializes separate local and remote ceph contexts. During initialization they use 'admin_socket' configuration parameter for admin socket path name. This usually leads to path name collision and admin socket binding failure (the only way to make them unique is to use '$cctid' meta variable for 'admin_socket' config setting, but then it is impossible for a user to know the path name in advance, which complicates its use).

As a result users can't run commands available via admin sockets, e.g. to dump perf counters statistics for the replayed images, which could be very useful for troubleshooting or developing statistics monitoring tools.


Related issues

Copied to rbd - Backport #20008: kraken: rbd-mirror: admin socket path names collision Rejected
Copied to rbd - Backport #20009: jewel: rbd-mirror: admin socket path names collision Rejected

History

#1 Updated by Mykola Golub 3 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Jason Dillaman 3 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #20008: kraken: rbd-mirror: admin socket path names collision added

#4 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #20009: jewel: rbd-mirror: admin socket path names collision added

#5 Updated by Nathan Cutler 2 months ago

@Jason There is no PoolReplayer::print_status in jewel, so the backport would have to be done manually in src/tools/rbd_mirror/Replayer.cc (looks like). However, the PoolReplayer::print_status in master is completely different from Replayer::print_status in jewel.

#6 Updated by Jason Dillaman 2 months ago

@Nathan: since this is more of a nice-to-have, I am also fine just dropping the need for a backport to jewel (and kraken is about to be replaced by luminous w/o a single point release).

#7 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF