Project

General

Profile

Bug #19877

check_past_interval_bounds assert after split

Added by Sage Weil 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
-
Start date:
05/06/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

- pg A is created in epoch X
- pg A does not go active
- pg A splits into pg B in epoch Y

but then,
- pg B has past intervals from [X,Y)
- pg B epoch_created is Y ***
- pg B required past intervals is [Y,Y)
- fails check_past_interval_bounds check

The problem is that we really want the pool creation epoch, not the most recent split epoch, and we don't have that.

History

#1 Updated by Sage Weil 2 months ago

  • Status changed from New to Need Review

#3 Updated by Sage Weil 2 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF