Project

General

Profile

Bug #19836

crush: encode weight_set in a pre-weight-set crushmap

Added by Loic Dachary 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/03/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

make crushwrapper encode a "legacy" crushmap if (1) we're using weight sets, (2) the client is lacking features for the weight set, but (3) the weight set has a single position and no id remapping. Since these maps are only used by clients (not humans), then i don't think there's any need to preserve the original crush weights in a shadow hierarchy; we can just swpa them for the real weights and the legacy clients wll behave as expected. a helper can tell us whether this is possible so that we gate any commands that inject crush map on a compat option.

History

#1 Updated by Loic Dachary 5 months ago

  • Description updated (diff)

#2 Updated by Loic Dachary 5 months ago

  • Source set to Development

#4 Updated by Loic Dachary 5 months ago

  • Status changed from In Progress to Testing

#5 Updated by Sage Weil 4 months ago

  • Status changed from Testing to Resolved

Also available in: Atom PDF