Project

General

Profile

Bug #19826

prime_pg_temp vs creation

Added by Sage Weil 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
-
Start date:
05/02/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

2017-05-02 13:09:16.975672 7fabdce7d700 20 mon.b@0(leader).pg v263  refreshing pg 141.6 0:0 creating
2017-05-02 13:09:17.842380 7fabd9676700 20 mon.b@0(leader).osd e226 prime_pg_temp 141.6 [2,5,1]/[2,5,1] -> [1,5]/[1,5], priming [2,5,1]
2017-05-02 13:09:18.068441 7fabda678700 20 mon.b@0(leader).osd e227 update_creating_pgs 141.6  acting_primary:2 -> 5
2017-05-02 13:09:18.068443 7fabda678700 10 mon.b@0(leader).osd e227 update_creating_pgs will instruct osd.5 to create 141.6
2017-05-02 13:09:18.068464 7fabda678700 20 mon.b@0(leader).osd e227 send_pg_creates will create 141.6 at 226
2017-05-02 13:09:18.068479 7fabda678700  1 -- 172.21.15.165:6789/0 --> 172.21.15.165:6808/28981 -- osd_pg_create(e227 141.6:226) v3 -- ?+0 0x559692a6bd40 con 0x5596911b8d00
2017-05-02 13:09:18.168588 7fabdce7d700 20 update_creating_pgs  141.6  acting_primary: 2 -> 5 acting: [2,5,1] -> [5,1] up_primary: 2 -> 1 up: [2,5,1] -> [1,5]
2017-05-02 13:09:18.285055 7fabdce7d700 20 mon.b@0(leader).pg v265  refreshing pg 141.6 0:0 creating
2017-05-02 13:09:19.168890 7fabdce7d700 20 update_creating_pgs  141.6  acting_primary: 5 -> 5 acting: [5,1] -> [5,1] up_primary: 1 -> 1 up: [1,5] -> [1,5,4]
2017-05-02 13:09:19.201933 7fabda678700 10 mon.b@0(leader).osd e228 update_creating_pgs will instruct osd.5 to create 141.6

but then
2017-05-02 13:09:18.068886 7facc47a9700 10 osd.5 226 handle_pg_create osd_pg_create(e227 141.6:226) v3
2017-05-02 13:09:18.077028 7facc7673700 10 osd.5 227 handle_pg_create osd_pg_create(e227 141.6:226) v3
2017-05-02 13:09:18.077033 7facc7673700 20 osd.5 227 mkpg 141.6 e226@2017-05-02 13:09:16.724380
2017-05-02 13:09:18.077040 7facc7673700 10 osd.5 227 mkpg 141.6  not primary (role=0), skipping
2017-05-02 13:09:18.109775 7facae06f700  1 -- 172.21.15.165:6808/28981 <== client.34721 172.21.15.195:0/2961171545 1 ==== osd_op(client.34721.0:2 141.6 141.7fc1f406 (undecoded) ondisk+retry+write+known_if_redirected e227) v8 ==== 188+0+128 (481648835 0 3503247227) 0x55e72dc08c00 con 0x55e72e351a00

because
    if (up_primary != whoami) {
      dout(10) << "mkpg " << on << "  not primary (role=" 
           << role << "), skipping" << dendl;
      continue;
    }
    if (up != acting) {
      dout(10) << "mkpg " << on << "  up " << up
           << " != acting " << acting << ", ignoring" << dendl;
      // we'll get a query soon anyway, since we know the pg
      // must exist. we can ignore this.
      continue;
    }

History

#1 Updated by Sage Weil 4 months ago

  • Status changed from In Progress to Need Review

and the main bug is that we shouldn't be priming creating pgs at all!

https://github.com/ceph/ceph/pull/14913

#2 Updated by Sage Weil 4 months ago

/a/sage-2017-05-02_10:48:00-rados-wip-sage-testing---basic-smithi/1092482

#3 Updated by Kefu Chai 4 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF