Project

General

Profile

Bug #19797

EINVAL: pool must only be stored on bluestore for scrubbing to work: osd.2 uses filestore from cephtool.yaml

Added by Sage Weil 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
-
Start date:
04/27/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

2017-04-27T14:01:02.293 INFO:tasks.workunit.client.0.smithi108.stderr:marked down
2017-04-27T14:01:02.306 INFO:tasks.workunit.client.0.smithi108.stderr://home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:718: fail_all_mds:  get_mds_gids cephfs
2017-04-27T14:01:02.306 INFO:tasks.workunit.client.0.smithi108.stderr://home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:710: get_mds_gids:  fs_name=cephfs
2017-04-27T14:01:02.307 INFO:tasks.workunit.client.0.smithi108.stderr://home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:711: get_mds_gids:  ceph fs get cephfs --format=json
2017-04-27T14:01:02.307 INFO:tasks.workunit.client.0.smithi108.stderr://home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:711: get_mds_gids:  python -c 'import json; import sys; print '\'' '\''.join([m['\''gid'\''].__str__() for m in json.load(sys.stdin)['\''mdsmap'\'']['\''info'\''].values()])'
2017-04-27T14:01:02.545 INFO:tasks.workunit.client.0.smithi108.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:718: fail_all_mds:  mds_gids=
2017-04-27T14:01:02.546 INFO:tasks.workunit.client.0.smithi108.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:722: fail_all_mds:  check_mds_active cephfs
2017-04-27T14:01:02.546 INFO:tasks.workunit.client.0.smithi108.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:689: check_mds_active:  fs_name=cephfs
2017-04-27T14:01:02.546 INFO:tasks.workunit.client.0.smithi108.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:690: check_mds_active:  ceph fs get cephfs
2017-04-27T14:01:02.546 INFO:tasks.workunit.client.0.smithi108.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:690: check_mds_active:  grep active
2017-04-27T14:01:02.727 INFO:tasks.workunit.client.0.smithi108.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:1001: test_mon_mds:  ceph fs rm cephfs --yes-i-really-mean-it
2017-04-27T14:01:04.827 INFO:tasks.workunit.client.0.smithi108.stderr:filesystem 'cephfs' does not exist
2017-04-27T14:01:04.839 INFO:tasks.workunit.client.0.smithi108.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:1005: test_mon_mds:  ceph osd pool set mds-ec-pool allow_ec_overwrites true
2017-04-27T14:01:04.997 INFO:tasks.workunit.client.0.smithi108.stderr:Error EINVAL: pool must only be stored on bluestore for scrubbing to work: osd.2 uses filestore
2017-04-27T14:01:05.014 INFO:tasks.workunit.client.0.smithi108.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:1: test_mon_mds:  rm -fr /tmp/cephtool.gV8

/a/sage-2017-04-27_13:22:48-rados-wip-sage-testing2---basic-smithi/1073370

History

#1 Updated by Nathan Cutler 6 months ago

  • Assignee set to Nathan Cutler

https://github.com/ceph/ceph/commit/a219319137e8ea269c7a8ca2652b68918c1c4c15 added "allow_ec_overwrites true" to qa/workunits/cephtool/test.sh

#2 Updated by Nathan Cutler 6 months ago

  • Status changed from New to Need Review

#3 Updated by Nathan Cutler 6 months ago

  • Status changed from Need Review to Testing

#4 Updated by Nathan Cutler 6 months ago

This is a different problem than I thought. The rados/singleton suite runs over a matrix of objectstores (bluestore-comp.yaml bluestore.yaml filestore-btrfs.yaml filestore-xfs.yaml). Putting an bluestore override into cephtool.yaml is ineffective, because it gets clobbered by, e.g., filestore-btrfs.yaml.

Looks to me like the cephtool.yaml needs to be split out into a bluestore-only subsuite.

#5 Updated by Sage Weil 6 months ago

  • Status changed from Testing to Resolved

Also available in: Atom PDF