Project

General

Profile

Bug #19756

fix failed to create bucket if a non-master zonegroup has a single zone

Added by Zhandong Guo 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
04/25/2017
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
jewel
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Release:
jewel
Needs Doc:
No

Description

If a non-master zonegroup has a single zone, the metadata sync thread not running and
the non-master zonegroup can't sync user from master zonegroup,
so we can't create bucket(or other metadata update) in it
because the authenticated user not found in the zone of non-master zonegroup.

The fix has been merged in kraken (https://github.com/ceph/ceph/pull/10991), We should backport for jewel


Related issues

Copied to rgw - Backport #19757: jewel: fix failed to create bucket if a non-master zonegroup has a single zone Resolved

History

#1 Updated by Zhandong Guo 7 months ago

This fix is important for online environment, please help to evaluate and backport for jewel if ok.

#2 Updated by Nathan Cutler 7 months ago

  • Status changed from New to Pending Backport
  • Target version deleted (v10.2.8)
  • Backport set to jewel

#3 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #19757: jewel: fix failed to create bucket if a non-master zonegroup has a single zone added

#4 Updated by Nathan Cutler 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF