Project

General

Profile

Bug #19658

"error calling conf_read_file: error code 22" means the Ceph conf file doesn't exist

Added by Alfredo Deza 8 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
ceph cli
Target version:
-
Start date:
04/18/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Similar to bug #10877 ("CLI error numbers are not described anywhere"). When trying to run any Ceph CLI commands on a cluster where the name is not 'ceph' this happens:

$ sudo ceph -s
Error initializing cluster client: Error('error calling conf_read_file: error code 22',)

But the configuration file is there:

$ ls /etc/ceph
ceph.d  rbdmap  test.client.admin.keyring  test.conf

In this case, it is 'test.conf'. It would be good to have an error that says what it looked for and why it failed (vs. function names and code numbers), for example:

$ sudo ceph -s
Error initializing cluster client: Error('tried to read /etc/ceph/ceph.conf but file does not exist') 

Other tickets opened that mention 'error code 22' that might be the same: #18000, #18001, #15884, #17238

History

#1 Updated by Alfredo Deza 8 months ago

Dan opened a PR to address most of the issues in this ticket: https://github.com/ceph/ceph/pull/14757

#2 Updated by Alfredo Deza 8 months ago

merged commit 4ba4567 into ceph:master

Not entirely sure how that output looks though, would be nice to have an update on that here

#3 Updated by Greg Farnum 6 months ago

  • Status changed from New to Resolved

Calling this done for now, since there were specific improvements. Other issues can get new tickets.

Also available in: Atom PDF