Project

General

Profile

Backport #19546

jewel integration branch fails to build for centos (regression)

Added by Nathan Cutler 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Release:
jewel

History

#1 Updated by Nathan Cutler 6 months ago

  • Description updated (diff)

#2 Updated by Nathan Cutler 6 months ago

  • Description updated (diff)

#3 Updated by Nathan Cutler 6 months ago

  • Description updated (diff)

description

This cannot be cherry-picked because master uses cmake instead of autotools.

https://github.com/ceph/ceph/pull/13606/commits/08a667883b68ccc72e3a4bc3013856deef1df93d, which enabled the OCF (ceph-resource-agents subpackage) build in the spec file, had the unfortunate side effect of breaking the CentOS build in Shaman.

Example build log: https://jenkins.ceph.com/job/ceph-dev-new-build/ARCH=x86_64,AVAILABLE_ARCH=x86_64,AVAILABLE_DIST=centos7,DIST=centos7,MACHINE_SIZE=huge/2408//consoleFull

#4 Updated by Nathan Cutler 5 months ago

  • Status changed from In Progress to Resolved
  • Target version set to v10.2.8

Also available in: Atom PDF