Project

General

Profile

Bug #19433

LibRadosWatchNotify.Watch3Timeout failure

Added by Sage Weil about 2 months ago. Updated 22 days ago.

Status:
Resolved
Priority:
Immediate
Assignee:
-
Category:
-
Target version:
-
Start date:
03/30/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

2017-03-30T21:11:14.250 INFO:tasks.workunit.client.0.smithi006.stdout:         api_watch_notify: [ RUN      ] LibRadosWatchNotify.Watch3Timeout
2017-03-30T21:11:14.250 INFO:tasks.workunit.client.0.smithi006.stdout:         api_watch_notify: waiting up to 8 for osd to time us out ...
2017-03-30T21:11:14.250 INFO:tasks.workunit.client.0.smithi006.stdout:         api_watch_notify: /mnt/jenkins/workspace/ceph-dev-new-build/ARCH/x86_64/AVAILABLE_ARCH/x86_64/AVAILABLE_DIST/centos7/DIST/centos7/MACHINE_SIZE/huge/release/12.0.0-1799-gc43910d/rpm/el7/BUILD/ceph-12.0.0-1799-gc43910d/src/test/librados/wa
tch_notify.cc:804: Failure
2017-03-30T21:11:14.250 INFO:tasks.workunit.client.0.smithi006.stdout:         api_watch_notify: Expected: (left) > (0), actual: 0 vs 0
2017-03-30T21:11:14.250 INFO:tasks.workunit.client.0.smithi006.stdout:         api_watch_notify: [  FAILED  ] LibRadosWatchNotify.Watch3Timeout (7028 ms)

/a/sage-2017-03-30_19:52:32-rados:thrash-wip-kill-subop-reordered---basic-smithi/967200
for one instance, but this has been happening a lot of the past week or so.

History

#1 Updated by Sage Weil about 2 months ago

/a/sage-2017-04-06_17:19:30-rados:thrash-wip-mgr-init---basic-smithi/993942

(and others)

#2 Updated by Sage Weil about 1 month ago

/a/sage-2017-04-21_02:10:47-rados-wip-sage-testing2---basic-smithi/1050871

#3 Updated by Sage Weil 25 days ago

/a/sage-2017-04-28_19:45:54-rados-wip-sage-testing---basic-smithi/1077726

#4 Updated by Kefu Chai 23 days ago

/a//kchai-2017-04-30_13:25:30-rados-wip-kefu-testing---basic-smithi/1085041

#5 Updated by Sage Weil 22 days ago

  • Status changed from New to Need Review

#6 Updated by Sage Weil 22 days ago

Confirmed that this was just because osd thrashing made us reconnect the watch. Extended the timeout so that we will eventually see it time out.

#7 Updated by Sage Weil 22 days ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF