Project

General

Profile

Bug #19429

qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test

Added by Kefu Chai 4 months ago. Updated about 1 month ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/30/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken,jewel,infernalis,hammer,giant,firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

see http://pulpito.ceph.com/kchai-2017-03-30_14:32:23-rados-wip-13999-kefu---basic-mira/966061/

2017-03-30T14:41:21.411 INFO:tasks.workunit.client.0.mira071.stderr:+ rbd export --export-format 2 testimg /tmp/rbd_import_export_13580/img_v2
2017-03-30T14:41:21.434 INFO:tasks.workunit.client.0.mira071.stderr:rbd: unrecognised option '--export-format'

was introduced by https://github.com/ceph/ceph/pull/10487


Related issues

Copied to ceph-qa-suite - Backport #19517: jewel: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test Resolved
Copied to ceph-qa-suite - Backport #19527: firefly: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test New
Copied to ceph-qa-suite - Backport #19528: hammer: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test In Progress
Copied to ceph-qa-suite - Backport #19529: giant: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test New
Copied to ceph-qa-suite - Backport #19530: infernalis: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test New
Copied to ceph-qa-suite - Backport #19531: kraken: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test Resolved

History

#1 Updated by Jason Dillaman 4 months ago

The test requests the "jewel" version of the "import_export" workunit but the HEAD version was downloaded instead -- this is a teuthology issue and potentially related to the workunit task change being tested.

#2 Updated by Kefu Chai 4 months ago

  • Status changed from New to Rejected

Jason, i am sorry for this (loud) noise. right, it's a false alarm, and it's a bug in my change of qa suite. dmick just fixed it.

#3 Updated by Kefu Chai 4 months ago

i reran the test with

teuthology-suite --filter="rados/upgrade/jewel-x-singleton/{0-cluster/{openstack.yaml start.yaml} 1-jewel-install/jewel.yaml 2-partial-upgrade/firsthalf.yaml 3-thrash/default.yaml 4-workload/{rbd-cls.yaml rbd-import-export.yaml readwrite.yaml snaps-few-objects.yaml} 5-workload/{radosbench.yaml rbd_api.yaml} 6-finish-upgrade.yaml 7-luminous.yaml 8-workload/{rbd-python.yaml rgw-swift.yaml snaps-many-objects.yaml}}" --priority 128 --suite rados --machine-type=mira --ceph master --ceph-repo https://github.com/ceph/ceph.git --suite-repo https://github.com/tchaikov/ceph.git --suite-branch wip-workunit-clone-with-branch

it still fails. but i think the reason is that the --suite-branch wip-workunit-clone-with-branch option overrides the default setting of workunit

tasks:
  workunit:
    clients:
      client.0:
        rbd/test_librbd_python.sh
    branch: jewel
...
overrides:
  workunit:
    sha1: 9ca7ccf5f1739f731da8bf31260594aea3a2932d
    branch: wip-workunit-clone-with-branch

so

$ grep 'git clone' /a/kchai-2017-03-31_04:34:21-rados-master---basic-mira/968824/teu*.log
2017-03-31T04:41:19.847 INFO:teuthology.orchestra.run.mira059:Running: 'rm -rf /home/ubuntu/cephtest/clone.client.0 && git clone --depth 1 --branch wip-workunit-clone-with-branch https://github.com/dmick/ceph.git /home/ubuntu/cephtest/clone.client.0 && cd /home/ubuntu/cephtest/clone.client.0'
2017-03-31T04:41:38.065 INFO:teuthology.orchestra.run.mira059:Running: 'rm -rf /home/ubuntu/cephtest/clone.client.0 && git clone --depth 1 --branch wip-workunit-clone-with-branch https://github.com/dmick/ceph.git /home/ubuntu/cephtest/clone.client.0 && cd /home/ubuntu/cephtest/clone.client.0'

in short, we cannot override the workunit's branch/sha1 if the qa test specifies a certain branch/sha1 for it workunit.

#4 Updated by Kefu Chai 4 months ago

  • Project changed from rbd to teuthology
  • Status changed from Rejected to Verified
  • Assignee set to Kefu Chai

http://pulpito.ceph.com/kchai-2017-03-31_11:34:14-rados-wip-kefu-testing---basic-mira/969210/

still fails, i ran this test using

teuthology-suite --priority 128 --subset 42/140  --suite rados --email tchaikov@gmail.com --ceph wip-kefu-testing --machine-type mira

#5 Updated by Kefu Chai 4 months ago

  • Status changed from Verified to Need Review

#6 Updated by Yuri Weinstein 4 months ago

We probably need this on kraken and jewel

#7 Updated by Jason Dillaman 4 months ago

  • Status changed from Need Review to Pending Backport
  • Backport set to kraken,jewel,hammer

#8 Updated by Jason Dillaman 4 months ago

  • Backport changed from kraken,jewel,hammer to kraken,jewel,infernalis,hammer,giant,firefly

#9 Updated by Nathan Cutler 4 months ago

@Jason - ceph-qa-suite was not migrated to giant or infernalis AFAICT . . . I guess that means it's now impossible to run teuthology on them.

#10 Updated by Kefu Chai 4 months ago

as jason pointed out, the root cause is https://github.com/ceph/teuthology/pull/1055,

#11 Updated by Kefu Chai 4 months ago

  • Project changed from teuthology to ceph-qa-suite

#13 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19517: jewel: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test added

#14 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19527: firefly: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test added

#15 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19528: hammer: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test added

#16 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19529: giant: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test added

#17 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19530: infernalis: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test added

#18 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #19531: kraken: qa/workunits/rbd/import_export.sh breaks jewel-x-singleton test added

#19 Updated by Kefu Chai about 1 month ago

  • Assignee deleted (Kefu Chai)

Also available in: Atom PDF