Project

General

Profile

Bug #19412

Crash in PyModules::shutdown when non-serve()'ing module is loaded

Added by John Spray about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
ceph-mgr
Target version:
Start date:
03/29/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Seen while writing regression test for http://tracker.ceph.com/issues/19258 -- I think others have been running on nodes that didn't have a dependency, so weren't loading the actual modules. It works fine without the fsstatus module loaded.

It's because we're calling the module's shutdown() in a finisher and then relying on the join() on the serve() thread to wait for that, which doesn't work if a module isn't serving anything.

History

#1 Updated by John Spray about 2 months ago

  • Status changed from In Progress to Need Review
  • Target version set to v12.0.0

#2 Updated by Kefu Chai about 1 month ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF