Project

General

Profile

Bug #18884

systemctl stop rbdmap unmaps all rbds and not just the ones in /etc/ceph/rbdmap

Added by David Disseldorp 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Low
Target version:
-
Start date:
02/10/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

Copy of downstream bug report:

When stopping the service rbdmap it unmaps ALL mapped RBDs instead just unmapping the ones configured in /etc/ceph/rbdmap.

Expectation is that starting the service maps and mounts only the ones listed in /etc/ceph/rbdmap and stopping the service unmounts and unmaps the ones configured.

Unfortunately it unmounts and unmaps also all other RBDs that were manually mapped and mounted and due to that can cause service interruption.


Related issues

Copied to rbd - Backport #19357: jewel: systemctl stop rbdmap unmaps all rbds and not just the ones in /etc/ceph/rbdmap Resolved

History

#1 Updated by David Disseldorp 9 months ago

I have a fix which uses an RBDMAP_UNMAP_ALL parameter in /etc/sysconfig/ceph to control whether all RBD images (if "yes, the default), or only images listed in /etc/ceph/rbdmap should be unmapped.

I'm unsure whether this makes sense, or whether I should just drop the unmap-all behaviour completely, and always consult the /etc/ceph/rbdmap list during unmap. Will ask for feedback in the upstream PR.

#2 Updated by Jason Dillaman 9 months ago

  • Status changed from Verified to Resolved

#3 Updated by Nathan Cutler 8 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to jewel

#4 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #19357: jewel: systemctl stop rbdmap unmaps all rbds and not just the ones in /etc/ceph/rbdmap added

#6 Updated by Nathan Cutler 7 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF