Project

General

Profile

Bug #18876

make check fails due to missing bc in ceph-helper.sh

Added by Kyrylo Shatskyy 6 months ago. Updated 24 days ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
Start date:
02/09/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
master
Needs Doc:
No

Description

Bunch of test are failing:

1 - test-ceph-helpers.sh (Failed)
5 - cephtool-test-mon.sh (Failed)
88 - test-erasure-code-plugins.sh (Failed)
89 - test-erasure-code.sh (Failed)
137 - osd-reuse-id.sh (Failed)
138 - osd-scrub-snaps.sh (Failed)

due to missing bc in ceph-helpers.sh:

/opt/j/ws/mkck/qa/workunits/cephtool/../ceph-helpers.sh: line 1096: bc: command not found
/opt/j/ws/mkck/qa/workunits/cephtool/../ceph-helpers.sh: line 1101: bc: command not found

Related issues

Copied to Ceph - Backport #20487: kraken: make check fails due to missing bc in ceph-helper.sh Resolved

History

#1 Updated by Kefu Chai 4 months ago

  • Status changed from New to Resolved
  • Assignee set to Kyrylo Shatskyy

#2 Updated by Nathan Cutler 24 days ago

  • Status changed from Resolved to Pending Backport
  • Backport set to kraken

#3 Updated by Nathan Cutler 24 days ago

  • Copied to Backport #20487: kraken: make check fails due to missing bc in ceph-helper.sh added

#4 Updated by Nathan Cutler 24 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF