Project

General

Profile

Bug #18675

client: during multimds thrashing FAILED assert(session->requests.empty())

Added by Patrick Donnelly 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
multi-MDS
Target version:
-
Start date:
01/25/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Component(FS):
Client
Needs Doc:
No

Description

2017-01-17T00:46:09.662 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr:2017-01-17 00:46:09.620870 7f5b005c0700 -1 client.4158 remove_session_caps still has dirty|flushing caps on 1000000007e.head(faked_ino=0 ref=6 ll_ref=3 cap_refs={4=0,1024=1,2048=0,4096=0,8192=1} open={1=0,2=0} mode=100666 size=4194304/16777216 mtime=2017-01-17 00:46:09.596951 caps=- dirty_caps=Fw objectset[1000000007e ts 0/0 objects 1 dirty_or_tx 4194304] parents=0x55688896f640 0x5568834cfe00)
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr:/build/ceph-11.1.0-6678-gda73c09/src/client/Client.cc: In function 'void Client::kick_requests_closed(MetaSession*)' thread 7f5b005c0700 time 2017-01-17 00:46:09.621159
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr:/build/ceph-11.1.0-6678-gda73c09/src/client/Client.cc: 2782: FAILED assert(session->requests.empty())
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: ceph version 11.1.0-6678-gda73c09 (da73c09995c9be5fca8d078223e0e9f3d071b2ab)
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x84) [0x7f5b09c490a4]
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 2: (Client::kick_requests_closed(MetaSession*)+0x629) [0x5568801fc1b9]
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 3: (Client::_closed_mds_session(MetaSession*)+0x7d) [0x5568801fc26d]
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 4: (Client::handle_client_session(MClientSession*)+0x29e) [0x5568801fc67e]
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 5: (Client::ms_dispatch(Message*)+0x46f) [0x55688023797f]
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 6: (DispatchQueue::entry()+0x78b) [0x7f5b09ca1f8b]
2017-01-17T00:46:09.663 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 7: (DispatchQueue::DispatchThread::entry()+0xd) [0x7f5b09d2bbed]
2017-01-17T00:46:09.664 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 8: (()+0x8184) [0x7f5b097b8184]
2017-01-17T00:46:09.664 INFO:tasks.cephfs.fuse_mount.ceph-fuse.0.mira033.stderr: 9: (clone()+0x6d) [0x7f5b088b937d]

from: http://pulpito.ceph.com/pdonnell-2017-01-16_23:40:01-multimds:thrash-wip-multimds-thrasher-testing-basic-mira/723474/

At first I thought the cause was that the MetaRequest was inserted multiple times into the session->requests xlist but apparently xlist doesn't allow that. That leaves the possibility that the MetaRequest is in session->requests but not in mds_requests. I didn't see a way for that to happen.

History

#1 Updated by Zheng Yan 9 months ago

  • Status changed from New to Need Review

#2 Updated by Zheng Yan 8 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF