Project

General

Profile

Bug #18416

"Error: Package: 1:ceph-selinux-10.2.0-0.el7.x86_64 (ceph)" in upgrade:jewel-x-kraken-distro-basic-vps

Added by Yuri Weinstein 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/04/2017
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/jewel-x
Release:
kraken
Needs Doc:
No

Description

This seems to be vps specific, similar tests on smithi ran fine (see here => http://pulpito.ceph.com/teuthology-2017-01-04_01:47:00-upgrade:jewel-x-kraken-distro-basic-smithi/).

Run: http://pulpito.ceph.com/teuthology-2017-01-04_04:20:04-upgrade:jewel-x-kraken-distro-basic-vps/
Jobs: ['686704', '686705', '686706', '686707', '686713']
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2017-01-04_04:20:04-upgrade:jewel-x-kraken-distro-basic-vps/686704/teuthology.log

2017-01-04T04:32:53.851 INFO:teuthology.orchestra.run.vpm157.stdout:--> Running transaction check
2017-01-04T04:32:53.854 INFO:teuthology.orchestra.run.vpm157.stdout:---> Package ceph-selinux.x86_64 1:10.2.5-5648.g5b402f8.el7 will be installed
2017-01-04T04:32:53.856 INFO:teuthology.orchestra.run.vpm157.stdout:--> Processing Dependency: selinux-policy-base >= 3.13.1-60.el7_2.9 for package: 1:ceph-selinux-10.2.5-5648.g5b402f8.el7.x86_64
2017-01-04T04:32:53.859 INFO:teuthology.orchestra.run.vpm157.stdout:---> Package hdparm.x86_64 0:9.43-5.el7 will be installed
2017-01-04T04:32:53.862 INFO:teuthology.orchestra.run.vpm157.stdout:---> Package python-babel.noarch 0:0.9.6-8.el7 will be installed
2017-01-04T04:32:53.864 INFO:teuthology.orchestra.run.vpm157.stdout:---> Package python-chardet.noarch 0:2.0.1-7.el7 will be updated
2017-01-04T04:32:53.869 INFO:teuthology.orchestra.run.vpm157.stdout:---> Package python-chardet.noarch 0:2.2.1-1.el7_1 will be an update
2017-01-04T04:32:53.872 INFO:teuthology.orchestra.run.vpm157.stdout:---> Package python-markupsafe.x86_64 0:0.11-10.el7 will be installed
2017-01-04T04:32:53.877 INFO:teuthology.orchestra.run.vpm157.stdout:---> Package python-urllib3.noarch 0:1.10.2-2.el7_1 will be installed
2017-01-04T04:32:53.880 INFO:teuthology.orchestra.run.vpm069.stdout:---> Package python-chardet.noarch 0:2.2.1-1.el7_1 will be an update
2017-01-04T04:32:53.887 INFO:teuthology.orchestra.run.vpm069.stdout:---> Package python-markupsafe.x86_64 0:0.11-10.el7 will be installed
2017-01-04T04:32:53.890 INFO:teuthology.orchestra.run.vpm069.stdout:---> Package python-urllib3.noarch 0:1.10.2-2.el7_1 will be installed
2017-01-04T04:32:53.893 INFO:teuthology.orchestra.run.vpm139.stdout:No package  available.
2017-01-04T04:32:54.392 INFO:teuthology.orchestra.run.vpm069.stdout:--> Finished Dependency Resolution
2017-01-04T04:32:54.397 INFO:teuthology.orchestra.run.vpm157.stdout:--> Finished Dependency Resolution
2017-01-04T04:32:54.592 INFO:teuthology.orchestra.run.vpm157.stdout: You could try using --skip-broken to work around the problem
2017-01-04T04:32:54.595 INFO:teuthology.orchestra.run.vpm157.stderr:Error: Package: 1:ceph-selinux-10.2.5-5648.g5b402f8.el7.x86_64 (ceph)
2017-01-04T04:32:54.601 INFO:teuthology.orchestra.run.vpm157.stderr:           Requires: selinux-policy-base >= 3.13.1-60.el7_2.9
2017-01-04T04:32:54.604 INFO:teuthology.orchestra.run.vpm157.stderr:           Installed: selinux-policy-targeted-3.12.1-153.el7.noarch (@anaconda)
2017-01-04T04:32:54.607 INFO:teuthology.orchestra.run.vpm157.stderr:               selinux-policy-base = 3.12.1-153.el7
2017-01-04T04:32:54.610 INFO:teuthology.orchestra.run.vpm157.stderr:           Available: selinux-policy-minimum-3.13.1-60.el7.noarch (base)
2017-01-04T04:32:54.612 INFO:teuthology.orchestra.run.vpm157.stderr:               selinux-policy-base = 3.13.1-60.el7
2017-01-04T04:32:54.616 INFO:teuthology.orchestra.run.vpm157.stderr:           Available: selinux-policy-mls-3.13.1-60.el7.noarch (base)
2017-01-04T04:32:54.618 INFO:teuthology.orchestra.run.vpm157.stderr:               selinux-policy-base = 3.13.1-60.el7
2017-01-04T04:32:54.620 INFO:teuthology.orchestra.run.vpm157.stderr:           Available: selinux-policy-targeted-3.13.1-60.el7.noarch (base)
2017-01-04T04:32:54.623 INFO:teuthology.orchestra.run.vpm157.stderr:               selinux-policy-base = 3.13.1-60.el7
2017-01-04T04:32:54.626 INFO:teuthology.orchestra.run.vpm069.stdout: You could try using --skip-broken to work around the problem

History

#1 Updated by Yuri Weinstein 10 months ago

  • Status changed from New to Rejected

Looks like this PR was at fault https://github.com/ceph/ceph/pull/12632

and https://github.com/ceph/ceph/pull/12773 should fix it

So closing for now

#3 Updated by David Galloway 10 months ago

Just for posterity, I believe the problem here is when minor distro version is not specified, 7.0 is the default OS version chosen downbursted for VPSes.

The package/dependency that's failing is newer than what CentOS 7.0 has.

Also available in: Atom PDF